Trunk problem

Hi,
i have an asteriskNow server running, and i tried to connect it with a lync server for sip calls.
so i have configured my asterisk manually without webGUi; and those are the modifications:

  • sip_additional.conf:

Code: Select all
[Lync_Trunk] ; Our Lync trunk
type=friend
port=5068 ; This is the default Lync Server Mediation TCP listening port
host=192.168.xx.35; This should be the IP address of your Lync Server
dtmfmode=rfc2833
context=from-lync
qualify=yes
transport=tcp,udp
insecure=invite

  • extensions_additional.conf

Code: Select all
[from-lync]

;Tous les numés à chiffres commençt par 2 vers les extensions Asterisk locales
exten=>_2XX,1,Dial(SIP/${EXTEN},20)
exten=>_2XX,n,hangup()


[from-internal-additional]
include => from-internal-additional-custom
include => app-recordings
include => app-calltrace
include => app-directory
include => app-echo-test
include => app-speakextennum
include => app-speakingclock
include => app-dialvm
include => app-vmmain
include => app-userlogonoff
include => ext-local-confirm
include => findmefollow-ringallv2
include => app-pickup
include => app-zapbarge
include => app-chanspy
include => ext-test
include => ext-local
include => outbound-allroutes
;Tous les numeros a 3 chiffres commencant par 1 vers le Trunk SIP Lync
exten=>_1XX,1,Dial(SIP/Lync_Trunk/${EXTEN},20)
exten=>_1XX,n,hangup()
exten => h,1,Hangup

when i tried to call a lync extension from an asterisk extension, i had this message on the asterisk CLI:

Code: Select all
== Using SIP RTP CoS mark 5
– Executing [[email protected]:1] Dial(“SIP/222-00000000”, “SIP/Lync_Trunk/111,20”) in new stack
== Everyone is busy/congested at this time (1:0/0/1)
– Executing [[email protected]:2] Hangup(“SIP/222-00000000”, “”) in new stack
== Spawn extension (from-internal, 111, 2) exited non-zero on ‘SIP/222-00000000’
– Executing [[email protected]:1] Hangup(“SIP/222-00000000”, “”) in new stack
== Spawn extension (from-internal, h, 1) exited non-zero on ‘SIP/222-00000000’

when I do a show peer i have this:

Code: Select all
asterisk*CLI> sip show peers
Name/username Host Dyn Forcerport ACL Port Status
222/222 192.168.xx.51 D A 59212 OK (126 ms)
223 (Unspecified) D A 0 UNKNOWN
224/224 192.168.xx.24 D A 5070 UNREACHABLE
Lync_Trunk 192.168.xx.35 N 5068 UNREACHABLE
4 sip peers [Monitored: 1 online, 3 offline Unmonitored: 0 online, 0 offline]

i can call from an asterisk extension to another asterisk extension, and from a Lync extension to another Lync extension… and when i call an asterisk extension from the lync extension, nothing happens on the asterisk side (no line added on the CLI)…what i need to know is: is my asterisk conf for this trunk good? thanks!