Trunk inbound error : Empty domain name in FROM header

Hello everyone,

I’ve sucessfuly instaled and configured my sip provider in free pbx but i can’t receive some calls.

I can make all outgoing calls whitout any problem
I can receive some incoming calls
I CAN’T receive some incoming calls with error:
“ERROR[2147][C-00000013]: chan_sip.c:19557 check_user_full: Empty domain name in FROM header”

I know chan_sip is deprecated but it’s not possible to set up my provider sip with pj_sip (don’t know why, I’ve followed other blogs and figured out how to do but only with chan_sip).

Anyone know if there is a reason for this? Why only from certain phone numbers?

I have tried the following:
Make a call with another phone from same provider: call ok
Make a call with another phone from other provider: call ok
Make a call with a specific mobile phone number: NOT OK
Make a call with the same specific mobile phone number but hidding the caller id in the cell phone: OK

Can anyone help? I’ve found some threads but nothing helpful

This is what I get when I try an incoming call from that specific number:
NOTICE[2147][C-00000013]: chan_sip.c:19547 check_user_full: From address missing ‘sip:’, using it anyway
ERROR[2147][C-00000013]: chan_sip.c:19557 check_user_full: Empty domain name in FROM header
NOTICE[2147][C-00000013]: chan_sip.c:19673 send_check_user_failure_response: Unexpected error for device tel:XXXXXXXXX;tag=p65540t1684936759m116297c117568s1_3909038812-963477769 for INVITE, code = -100

The From header contains a tel URI, and chan_sip’s support for that is iffy at best.

Try pjsip, after confirming that you are running Asterisk 16.29.0, 18.15.0, 19.7.0, 20.0.0 or better.

I’m sorry, I’m new at this. Your answer means that it’s not possible to receive this calls?

I would like to but as I mentioned I can’t use pjsip to my sip provider

If you can’t use chan_pjsip with the provider you need to change either your provider or PABX. If you only mean that they won’t provide you with a canned configuration, you should create your own from first principles (most canned configurations for chan_sip, are actually wrong).

It is possible that they said you cannot use chan_pjsip because they tested on a version earlier than those listed above. In that case, it would have rfefused to use the TEL: URs whereas chan_sip will accept them, but may not then behave reliably. Later versions of chan_pjisp support the more common uses of TEL: URIs, but still can’t send them.

If it’s not working, then it’s likely not possible to make chan_sip work without code modifications.

Please post the settings you tried and the error you got.

Or, post your chan_sip settings and we’ll try to give you the pjsip equivalent. When you redact the chan_sip information, make it clear what each item is. For example, replace username with uuuuu, auth user (if different) with aaaaa, password with ppppp, and so on.

I apreciate. Here are my chan_sip settings. I followed your sugestion user uuuuu, pass ppppp, server hhhhh, proxy ooooo

sip setting
Outgoing tab:

Incoming tab:
User context and user details: empty
Register string:

After hundreds of try and error I’ve sucessfuly configured pjsip (after provider costumer support said that is not possible).

Thanks to who tried to help

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.