Trouble updating XMPP - MongoDB not installed

Trying to update XMPP and I get the following error:

Installing xmpp
Installing/Updating MongoDB…MongoDB is not installed
Error(s) installing xmpp:
Failed to run installation scripts

I can’t find a module “MongoDB”. How can I install MongoDB?

Thanks,

Yum install

Thank you, I had tried Yum Install prior and couldn’t get it to work. After more research I found I had to first create the repository.

https://docs.mongodb.com/manual/tutorial/install-mongodb-on-red-hat/

No. You now have a conflicting repository. This will cause issues in the future. You probably have’t run any of the upgrade scripts for your system.

I always upgrade using the module admin in FreePBX. Do I need to run upgrade scripts in terminal?

In addition to FreePBX modules, you want to keep your distro current using the upgrade procedure noted here:
https://wiki.freepbx.org/display/PPS/FreePBX-Distro-10.13.66

System Admin Pro allows you to do it from the GUI.

I have system admin pro and it is set to automatically update. Wouldn’t that update have installed MongoDB?

Log of latest upgrades. Looks like the latest one was today.

2017-03-14 00:18:13: () Update sequence initialized
2017-03-14 00:18:13: (6.12.65-22) Upgrade process successfully completed!
2017-03-21 00:18:06: () Update sequence initialized
2017-03-21 00:18:06: (6.12.65-22) Upgrade process successfully completed!
2017-03-28 00:18:10: () Update sequence initialized
2017-03-28 00:18:11: (6.12.65-22) Upgrade process successfully completed!
2017-04-04 00:18:07: () Update sequence initialized
2017-04-04 00:18:07: (6.12.65-22) Upgrade process successfully completed!
2017-04-11 00:18:06: () Update sequence initialized
2017-04-11 00:18:06: (6.12.65-22) Upgrade process successfully completed!
2017-04-18 00:18:14: () Update sequence initialized
2017-04-18 00:18:14: (6.12.65-22) Upgrade process successfully completed!
2017-04-25 00:18:05: () Update sequence initialized
2017-04-25 00:18:05: (6.12.65-22) Upgrade process successfully completed!
2017-05-02 00:18:08: () Update sequence initialized
2017-05-02 00:18:08: (6.12.65-22) Upgrade process successfully completed!
2017-05-09 00:18:05: () Update sequence initialized
2017-05-09 00:18:05: (6.12.65-22) Upgrade process successfully completed!
2017-05-16 00:18:11: () Update sequence initialized
2017-05-16 00:18:11: (6.12.65-22) Upgrade process successfully completed!

You are running FreePBX 13, but you are still running distro firmware 6.12. Get your distro current by running the final script on this page to transition to 10.13.x

https://wiki.freepbx.org/display/PPS/FreePBX-Distro-6.12.65

1 Like

Thanks Lgaetz.

I ran the command and received an error about a certificate. Is it safe for me to use the “–no-check-certificate” command? I don’t want to screw anything up.

[[email protected] ~]# cat /etc/schmooze/pbx-version
6.12.65-32
[[email protected] ~]# mkdir upgradescripts
[[email protected] ~]# cd upgradescripts/
[[email protected] upgradescripts]# wget https://upgrades.freepbxdistro.org/stable/10.13.66/upgrade-10.13.66-1.sh
–2017-05-16 13:38:16-- https://upgrades.freepbxdistro.org/stable/10.13.66/upgrade-10.13.66-1.sh
Resolving upgrades.freepbxdistro.org… 199.102.239.49
Connecting to upgrades.freepbxdistro.org|199.102.239.49|:443… connected.
ERROR: no certificate subject alternative name matches
requested host name “upgrades.freepbxdistro.org”.
To connect to upgrades.freepbxdistro.org insecurely, use ‘–no-check-certificate’.

Yes. Please use that command line option

Thank you! I have the system updated.

1 Like