Trouble registering Grandstream WP825


I’ve been trying to get a Grandstream WP825 to register on FreePBX.

I’ve tried multiple variations of this page - One with the Authenticate ID being the same as the SIP User ID and currently trying it without it. I’ve tried both the UCP password and the secret. Used the hostname and the IP for it, the SIP Server.

For the Network settings, I haven’t tried much other than changing the NAT Traversal and DNS Mode

I’ve tried changing the Local SIP Port and TEL URI.

Is there something I have done wrong? The setting for the extension are pretty much default. Doing a packet capture on the phone and looking at it in Wireshark, I couldn’t see any SIP packets.

Any help would be greatly appreciated.

Can you post some SIP or asterisk logs of when you have the phone trying to register?

I’ve got lots of users on the system, I’m not an expert on the logs, how should I go about filtering them to find the phone trying to register.

I am able to get it to register with chan_sip, but I have been slowing moving all of our endpoints to chan_pjsip.

I went looking through the logs in /var/logs/asterisk and found this in fail2ban

[2023-06-21 14:13:08] NOTICE[8053] chan_sip.c: Registration from '<sip:[email protected]>' failed for '' - Wrong password

218 is a pjsip extension, would it be saying chan_sip? And I’ve copied the password directly from the extension so I’m not sure how it could be the wrong password.

Because the phone is incorrectly attempting to register to the chan_sip bind port.
In Asterisk SIP Settings, chan_pjsip tab, look for a section probably called (udp) .
Check the value of Port to Listen On .
In the phone settings, the value of SIP Server should be the host name or IP address, followed by a colon and the port number you saw for Port to Listen On. For example,

Of course, use the actual host name or IP address of your PBX, and the actual value of Port to Listen On.

If you still have trouble, post what now appears in the Asterisk log when it attempts to register.

Looks to be on 5164 which is what I’ve set the local SIP port in the Basic Settings in the phone (I have since changed it to what is in the picture)

I’ll give this a try.

The Local SIP Port setting in the Grandstream is the port number at the Grandstream end. Except in unusual circumstances it can be anything, with no effect.

Make sure that SIP Server has
and retest.

Yep it works!

Thank you

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.