Transfer to Voicemail Doesn't Work


I’m trying to setup transfer to voicemail on our system, where a receptionist can transfer a call directly to another staff members voicemail. My understanding is that I would need to transfer a call to ##*201 to blind transfer a call to voicemail 201. Unfortunately, this is currently bringing back an unknown number error.

Does anyone know what I could be doing wrong?


In your Admin settings, there should be an item called “Feature Codes”. Double check your settings and make sure the Blind Transfer function is “##”.

Also, some phones require you to put a “#” on the end of that to immediately dial.

If you turn on SIP Debug, you can monitor what is actually getting sent from the phone to the server and maybe pick up some more information.

Now, failing this, you could set up an extension (call it 1201) that has, as it’s destination, the voicemail box for 201. That might help by getting the '*" out of the mix.

1 Like

Blind transfer is showing ## and is enabled. I can’t even dial the ##*201 command right now as once I press # is brings back unknown number. Here are the logs I was able to pull:

[2017-03-28 12:45:32] VERBOSE[10344] : -- SCCP: Got digit timeout char '#', dial immediately
[2017-03-28 12:45:32] VERBOSE[10344] : -- SCCP/205-00000004: stop schedule digittimeout 12
[2017-03-28 12:45:32] VERBOSE[10344] : -- SEPMACMACMAC: (sccp_pbx_softswitch) New call on line 205
[2017-03-28 12:45:32] NOTICE[10344] sccp_pbx.c: SEPMACMACMAC: Call from '205' to extension '', rejected because the extension could not be found in context 'from-internal-xfer'
[2017-03-28 12:45:32] NOTICE[10344] sccp_pbx.c: SEPMACMACMAC: Scheduling Hangup of Call: SCCP/205-00000004
[2017-03-28 12:45:32] VERBOSE[10344] : -- +- pbx extension matcher ( ): ---+
-- |ignore |exists |can match |match more|
-- | no | no |yes |yes |
-- +----------------------------------------------+
[2017-03-28 12:45:32] VERBOSE[10344] : -- SCCP/205-00000004: Matches More
[2017-03-28 12:45:33] VERBOSE[10344] : == SEPMACMACMAC: Ending call SCCP/205-00000004 (state:INVALIDNUMBER)
[2017-03-28 12:45:33] VERBOSE[10344] : -- SEPMACMACMAC: Sending hangupRequest to Call SCCP/205-00000004 (state: INVALIDNUMBER)
[2017-03-28 12:45:33] VERBOSE[10344] : -- QualityStats: MLQK=0.0000;MLQKav=0.0000;MLQKmn=0.0000;MLQKmx=0.0000;ICR=0.0000;CCR=0.0000;ICRmx=0.0000;CS=0;SCS=0;MLQKvr=0.95
[2017-03-28 12:45:33] VERBOSE[10344] : -- SEPMACMACMAC: Call Statistics:

In your sccp.conf file, what context did you specify?

As I pointed out in the Wiki article, I always use “from-internal” so that I can avoid strangenesses like this. This way, “*65” for “who am I” works…

The “##” for unattended transfer works in Chan-SCCP-B - I use it. In this case, however, you might want to use “2201#” and use the attended transfer shortcut.

I had used context = from-internal-xfer, but I just switched it to context = from-internal, rebooted the system, and the same issue occured.

This seems to have something to the fact that pressing # forces the phone to dial immediately. I tried changing the ## transfer to something else such as *#, but once the # was pressed, it again dialed and returned an unknown number error.

EDIT: It looks like this may be caused by the lack of a new dialplan.xml file with an allowance for the # key to be used.

There’s an option you can specify in the sccp.conf file that turns off immediate processing of the immediate dial code (#).

I don’t have any dialplan XML files anywhere, so I doubt that’s what’s causing your immediate problem.

digittimeoutchar = # is shown in the wiki as the option to turn the # to dial option on, however it’s not showing in my sccp.conf which would seem to imply the option is turned off… Might have to check with the chan-sccp folks on this one.

EDIT: Ok, this was me being stupid. Turns out I was pressing transfer then ##, instead of ## while still on the phone. Once I got that right, then the issue disappeared.