FreePBX | Register | Issues | Wiki | Portal | Support

Transfer to Voicemail button

voicemail
asterisk
Tags: #<Tag:0x00007f749f2baf28> #<Tag:0x00007f749f2bade8>

(LigerXT5) #1

I’m in the middle of an interesting puzzle of transferring active calls to specific extension’s voicemail with a press of a button.

One of our client users has a sidecart for their Grandstream GXP2170, solely for transferring calls to specific extension’s voicemails as needed.

The call comes in, the front desk takes the call and routes it as needed. If the extension to be transferred to is unavailable for calls (yet their DND is not turned on…), the call is to be sent straight to voicemail, without ringing the phone. The front desk would press the transfer-speeddial button to transfer the call to that extension’s voicemail.

I have the sidecart’s buttons set as Transfer > *103 for an example.

I’ve thumbed down the issue to be using buttons, as manually hitting transfer, then *, followed by the extension. I currently have featurecodes such as *1, *10, *11, and *12 disabled, as they were conflicting, and now transfer to voicemail work.

Other than *1, the others are not used. I’ve changed *1 to **1 for continued use. I’ve tried changing the transfer to voicemail feature code to use **, however the Grandstreams displays on screen, no audio recording, I don’t have the exact wording off hand, not matching dialplan.

I’m looking to see if there are better solutions to this issue. As far as I’ve seen, disabling *10, *11, and *12, and changing *1 to **1 has been the best alternative. As I write this, I realized I didn’t test and confirm **1 is a conflict while in an active call, though it’ll be manually pressed when needed.


#2

How about setting up a ring group for each extension with say a 1 in front that does not actually ring anything but delivers the vm for the correct extension or create a dummy extension with no phone registered that sends the call to the correct voicemail ?


(LigerXT5) #3

As those are suggested idea, I’m glad the client doesn’t have a 50 or 100 extensions, just 16, give or take, voicemail enabled extensions. lol


#4

So, what is the puzzle/issue you never mention?


(LigerXT5) #5

I’ll alter the post, the puzzle is, manually using Transfer > * > Extension, the transfer works. Setting it up with a one press Transfer button with *Extension, fails if I leave *1, *10, *11, and/or *12 feature codes enabled.

I’m sure there is a standard way of setting up a Transfer to Voicemail VMK/Speeddial, however I have not figured this out.


#6

The code to do a blind transfer is ## . So why not do a DTMF code for ##* on a button?

The caller will hear it, but it will work


(LigerXT5) #7

Ran your suggestion.
Created a VMK as Dial DTMF on the phone, with ##*105. The phone dialed ##*105, then nothing happens. The other end, my cell, heard the key presses.


(Dave Burgess) #8

I think you need a pause after the ##, but it’s entirely possible I’m full of it.


#9

Make sure you have not disabled, or changed the blind transfer transfer code.


(LigerXT5) #10

I’m not entirely sure how I’d add a pause in the VMK.


(LigerXT5) #11

Double checked my, and the client’s, PBX. Blind Transfer is enabled and not customized.


#12

Try dialing it manually just to test?


(LigerXT5) #13

With an active call, I pressed ##*105 and waited. No reaction.

Just to confirm, I pressed Blind Transfer, *105 (during which my cell had hold music), then Blind Transfer. Went to voicemail.


#14

Maybe try a speed dial for ##*105?

I do know pressing ## on the keypad on my systems do work while in a call.


(LigerXT5) #15

That idea had an interesting reaction.
Speed Dial of ##*105, placed the call on hold (with music), allowing me to hit the Resume button on the phone to pick up the call.


#16

I just did a quick test. After I pressed ## the call when directly to hold and wanted me to press an extension to transfer to


(Tom Ray) #17

The thing with Feature Codes is they are dialable codes. So you have to be careful to not have conflicts. FreePBX makes * the “direct to voicemail” code. But if you have ext 105 AND using speed dials then dialing *105 will look for speed dial 5 since *10 is the speed dial code.

Using ## is not a workaround as it still dials *105 and will be caught be the speed dial code.

Nothing is to say you have to use the feature codes as is. Some exist as the default to match their old school POTS vertical codes (*72, *68, *69, etc) the rest are there as a code to use.

The simple fix is to update your feature codes to something that doesnt conflict with your extensions and other dialable destinations.


(LigerXT5) #18

Thank you all for your suggestions. For our smaller clients, and depending on how the conflicts may come up, we will do the disable/change of feature codes. For larger client bases, may have to create a second run of extensions that fail over to the respective’s voicemail. Neither are clean methods in my opinion, but does accomplish the tasks and runs smoothly for the clients.

Thank you all once again!


#19

Hi There,

On Grandstream phones you should also activate the “allow dtmf via mpk” option so DTMF’s will actually go out when sending them. Also, set the button to ##*105#


(system) closed #20

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.