Transfer Not Working Yealink T28P


I am running FreePBX

When i try to transfer a call using my yealink phone’s transfer (this is an Attended Transfer) button it connects to other ext then then i hit transfer again to leave the call and let the transfer proceed it says “transfer failed”.

when i use the dial code ## for blind it works.
when i use *2 attended transfer it works and connects them when i hang up.

Any ideas on why the yealink transfer button does not complete the transfer?

i also have Ring Central on this same yealink phone and the transfer button works fine.

Could it possibly be an issue with the Firmware on your Yealink phone? Ours are running and this function is working just fine.

There are also some settings on the phone itself. Ours are currently set to:

That appears to work well for us.

Hey Chalky,
I took a look i was actually running a earlier firmware 2.70xxx

i found an upgrade and am now on which actually has some cool new features like it now shows you an auto complete based on history and phone book when you star dialing like in google.(verry cool and usefull)

sad to say the transfer still will not work… and my transfer setting match yours. any other ideas?

max123 : anything new ?
just bought some T28P and I read now for your problem…

not as of yet… but the ## or *2 works fine just not the phones transfer button. and it seems to work fine with other carriers setup on my phone not on freepbx.

did you try it?

No , bought online, phones aren’t arrived yet…

i really think these phones are a great value… they work great aside from this issue… there’s no reason to spend double the money for a similar featured phone in another brand… i spent $120 on the T28P’s and about $80 on T26P’s they are working great.

i also tested on Yealink T26 and got same result.
could it be a freepbx configuration?

freepbx 4.211.64 and it worked just fine

Someone pointed out that i was hitting transfer then the ext then # … when i left out the # after the ext transferred to it seems to work.