FreePBX | Register | Issues | Wiki | Portal | Support

Tranferring calls does not complete


(Cory Cook) #1

When someone calls into the PBX, the call is answered and transferred to another extension. The user on the other extension hears the phone ring, and picks up the phone, but the call transfer doesn’t appear to complete. The caller that is being transferred only hears MOH forever, until they disconnect.


(Dave Burgess) #2

Just checking - the sequence for transferring a call is “transfer” “extension number” “transfer”.

The last transfer completes the sequence.


(Cory Cook) #3

Hi Dave,

Thanks for the reply. That is where my confusion lies. I don’t see anything that looks like an issue, however, when the transferred call is “picked up”, the caller is just left in limbo, listening to MOH. Would enabling debugging assist in seeing what’s going on?


(Dave Burgess) #4

Looking at the logs, it looks like you are trying to use Zulu to answer the call and initiate the transfer? If so, which version of Zulu are you using?

Also, I don’t see the Zulu call ever getting transferred.

This looks like it could be a bug. Maybe @tm1000 can look at it and see if it’s something in the Zulu code or something in the way you are initiating the transfer.


(Cory Cook) #5

Thanks again Dave. I know the Zulu module is installed and up to date, and that at one time, we tried to use it with the Zulu softphones, but were unable to get it to work reliably. As of now, the module is installed, but not being used at all.
As far as the procedure, the receptionist @101 answers the call, hits transfer (Sangoma S500), dials the extension, hits send, lets the user know there is a call, then hits transfer again. The call appears to be transferred, but never completes.


(Andrew Nagy) #6

Please post log files an pure text and not screenshots.


(Cory Cook) #7

I tried to, but it was too many characters


(Itzik) #8

You can use pastebin, documented in the Wiki.


(Cory Cook) #9

I think I did this right:

https://pastebin.freepbx.org/view/72c9c9a7 - call transfer
https://pastebin.freepbx.org/view/47ec9908 - initial inbound call


(system) #10

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.