TLS and SRTP with PjSip - PjSip option greyed out

Hi, I’m trying to see why I can’t seem to set the default TLS port assignment to PjSIP in Freepbx 15. Specifically, the option is graded out under Settings >> Asterisk SIP Settings.

According to the documentation, it seems that it requires port 5061. From what I gather, VOIP.MS only allows 5060, 5080, right?

I simply want to secure my connection between me and you – I suspect that I get too many fraudulent or phishing calls as of late and they my have intercepted my communication. I’m not sure.

This is the documentation from Sangoma WIKI. I think that I have all the requirements listed in the WIKI.

if you could share with me what I’m missing, I’d appreciate it.

Not what says! In fact they specifically say that 5060 and 5080 cannot be used for TLS.

Either they come via, and encryption will make no difference, or white listing only’ IP addresses should be pretty effective.

I doubt much interception happens outside of your own premises, unless you are of interest to state sponsored actors, but I could be wrong.

This is the official reply from on this issue.


We support ports 5061, 5081 and 42873 for TLS connections. For UDP/TCP we use the ports 5060, 5080 or 42872. for PJSIP trunks I recommend you check our wiki page

If you plan on using a TLS connection then please make sure you enable Encrypted SIP traffic for the account you’re trying to register. For the main account this option can be found in the account settings page > advanced settings tab; for the subaccounts this is found in the Manage Subaccount page > edit subaccount > advanced settings options.

I hope this helps everyone.

@david55 , I think you’re right. implementing TLS isn’t going to help me. I implemented TLS and still got fraudsters calling my lines. I think that they are cycling the numbers since my numbers are in sequence – yes, we got calls one after another.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.