Time conditions not making it into extensions_additional.conf

Hi all

I’ve installed Asterisk and FreePBX on two openSUSE 10.3 servers. I am having the exact same problem on both (separate installs, one at home, one at work)

Originally voicemail wouldn’t work, I fixed this by removing and reinstalling the Voicemail and Feature Codes modules.

However the same treatment isn’t solving my problem with Time Conditions.

The web interface for setting up time conditions is fine, and I can point to the one I made from an inbound route and day/night toggle fine, but the [timeconditions] section in extensions_additional.conf just simply isn’t there. To get things going for now I’ve had to manually put my own in extensions_custom.conf.

Why would this happen? I’m unable to tell.

Any pointers would be greatly appreciated.

I’m running FreePBX, Time Conditions module, on Asterisk 1.4.14.