Time Condition: "Current: Unknown State"


#1

My time conditions are not working despite the Server time showing as correct in Time Groups.

In the Change Override option it shows:
Current: Unknown State

The only way that I can get it to work is by setting an override.


(Ira Holden) #2

All your Time Conditions don’t work?
If so, have you tried a different Time Group?

Has your time zone been assigned? I believe once set, the box has to be rebooted.

Have you tried to delete both the Time Conditions and Time Group just to make sure it’s not a database issue.


(S L) #3

@mrjoe are you on version 15?

I am also having this issue and on the PBXAct platform. I’ve not engaged support yet and will likely perform an update first just to make sure it’s not already fixed. However, I’ll note that I’ve noticed this issue for several weeks since our upgrade to v15 but thought it was normal. Up until today, when a user started reporting that department voicemails were incorrectly being deposited into another department’s mailbox - was when I started digging into the issue. Which, when calling one of the department’s main line - the time condition was in after hours, even though the time condition should be in regular hours. Temporarily matching the override resolved it for now, but the current condition still states Unknown State instead of their override condition.

Update 1:
After performing an update to the latest version and looking at the Time Conditions module - it seems the issue may have been fixed and each time condition is reporting “No Override” - which is the correct state.

Update 2.
I spoke too soon. Inside Time Condition and then an actual time condition - the state is still Unknown. We’ve created a case with Sangoma.

PBXAct Version: 15.0.16.75