Time and date keep randomly changing

the time doesn’t seem to stay on our phones. If the phone reboots, it resets. Yealink T46s phones, freepbx 14. Anyone seen this?

What do you mean it resets? What does it reset to? When you look at the phone itself, what are the date/time settings?

if the phone reboots, the time gots back to 12:00am and the date and year are all wrong. I’ve never seen this. current firmware on 20 phones

So they are running What are the settings in the phone in regards to it’s time/date?Is it using DHCP? Is it not? There are various phones settings for this. Show a screenshot of the time/date settings for a phone that is having this issue.

yes that is the version. Weird thing is if I register a phone offsite to the same PBX, the time is correct. Firewall?

Need confirmation of what this phone is using to source its date/time. I’m not sure how the firewall would be the issue more like DHCP. So please show the screenshot.

What is it with people not giving the information asked and still expecting answers.

What does this look like for you @sentinelace

Normally I just set the PBX to the time zone and it always works. I tried from DHCP with same result.

Does any of that change when this happens? The settings are always the same? Because it’s looking like you’re not getting any traffic back for the NTP server.

If the time/date is going to 12:00AM Jan/01/1969 or something like that then the phone has lost connection or not getting details from the NTP server when it is rebooted.

How do you reset the time with this happens?

If I reboot the phone, it resets, even if I set the time manually on the phone. It says May 17 12:00am every time the phone reboots. would the traffic be blocked by the ISP? how do we troubleshoot this?

No, probably by you. ISPs don’t block NTP servers. What do you have at this place with the phones in regards to a router/firewall?

Dump the local log.

Open the sys.log and search for ntp_state

That will tell you if the phone is talking to the NTP server or not. But it definitely sounds like it is not.

Do you not have a local NTP server? Most routers do this, that is why my screenshot shows the local router as the first NTP choice. If you have a Windows network, all Windows Domain Controllers do this by default I believe.

I have a sonicwall connected to DSL. I have this same setup and config at 50 other locations, no time issues

ntp_state=0 is what the log shows

This is obviously not true. something is different whether you think so or not.

the difference is the ISP, we have never used them. We are checking with the configuration of the DSL modem

I resolved the issue. DSL provider provided wrong DNS settings

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.