The third day of installation. After installation: Permission denied

Hello!
I have installed FreePBX on Centos 7. But i cant see the Admin setup page.
For instalation i used that help Installing+FreePBX+14+on+CentOS+7 from this site.
But i see white screen with errors.

Warning: include_once(/etc/freepbx.conf): failed to open stream: Permission denied in /var/www/html/admin/config.php on line 100

Warning: include_once(): Failed opening ‘/etc/freepbx.conf’ for inclusion (include_path=’.:/usr/share/pear:/usr/share/php’) in /var/www/html/admin/config.php on line 100

Fatal error: Class ‘FreePBX’ not found in /var/www/html/admin/config.php on line 110

Warning: Unknown: open(/var/lib/php/session/sess_ce5490l2r3shu42p4it4qqtdl1, O_RDWR) failed: Permission denied (13) in Unknown on line 0

Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/var/lib/php/session) in Unknown on line 0

Set permission to folder /var/lib/php/session/ not help.
I have tried “fwconsole chown” - the same result.
Please, help!

Hi, I’m not the expert, also not familiar in command line.
Basically, I will log in CentOS to check this type of issue, you can follow the CentOS GUI installation if you are interesting:

yum groupinstall “Desktop”
yum groupinstall “X Window System”
yum install xorg-x11-fonts-Type1
yum install gnome-packagekit gnome-packagekit-extra

After that you run this command to start the GUI desktop:

StartX

The GUI is more easy for me to do the troubleshooting

I must run this command on VPS server?

Installing the full X11 desktop environment on your linux server is strongly dis-advised. Not only is it resource intensive but it can also be a future attack vector to which you are not aware it’s running or installed.

Servers are meant to be CLI tools. When you see a webserver or go to a webpage they are not running a full X11 desktop in the background, you shouldn’t either.

This issue sounds like selinux is enabled. Disable it here: https://www.centos.org/docs/5/html/5.1/Deployment_Guide/sec-sel-enable-disable.html

1 Like

No, selinux is disabled, it is first thing that i have checked ((

/etc/sysconfig/selinux

SELINUX=disabled.
SELINUXTYPE=targeted

Then I assume the apache user can’t access /etc/freepbx.conf you’ll have to figure that one out yourself.

A custom install of FreePBX on a VPS that you don’t have access to on an unsupported operating system is 7th level Mage stuff. You need a reasonable level of Linux experience and an understanding of you the different packages work together, as well as a relatively deep understanding of Asterisk before you should attempt this.

I’m not saying quit, or that we can’t help you, but you’re going to have to tell people what is working, as well as what isn’t, before most people are going to be willing to help you. Specifically, when the SELinux idea was floated, your effective response was “nope, guess again.” There are literally a thousand things that could be wrong, but no one wants to hold your hand through each and every possibility until one of us guesses right.

For example. your first post was a reasonable start:

OK - who owns it? Who did you start the process as? Does the file exist? Can you open it when logged into the console as ‘root’? Can you log in as ‘root’? Can you log in as ‘asterisk’?

This is a ‘roll your own’ installation, so you either need to tell us everything or start over. There’s a reason the system comes with a full load of the operating system and all of the packages - this is a beast. You’re not installing a new version of “Angry Birds”, your installing an Industry Class Public Branch Exchange Telephone System.

We want to help, but we need you to help too.