The ring seconds doesnt work in FreePBX?

Hello, I have the ring group of one area set to 120seconds, so that if someone is calling, his call should ring for 120 seconds trying to reach someone, but right now, it automatically goes to busy mp3 saying all are busy.

SO, is it a bug ?

Isn’t that feature working ?

No telling. You need to paste the call log here

If all of the extensions in a ring group are busy, where exactly are you expecting the ring group to ring? There’s nothing that can ring, so the group is busy. Sounds like the system is working precisely the way it’s supposed to.

If you want something that rings when all of the extensions in the group are busy, you need a queue.

all are sitting free and chilling here in office, but still it doesnt reach, thats the issue :smiley:

CDR report or which log to explain it better ?

The log file /var/log/asterisk/full will give you the most visibility into this.

That’s actually not true. There is an setting in Ring Groups “Skip Busy Agent” its default setting is “No” so that busy agents will still be rung. So that statement is just not true.