The person at ext xxxx is on the phone but they aren't

Hello. I’m very very new to this but would like to learn more. I’ve managed to setup the freepbx and have it working with 5 extensions, local and remote. The issue I’m having is when I dial extension number 202 from extension 200 I get the message "The person at extension number 202 is on the phone please leave a message. All the other phones can dial 202 and it rings with no problem. It is only form EXT 200 that this happens. I’ve deleted EXT 202 and re made it but It still doesn’t work. I’m now bald as I’ve been pulling my hair out over this.The freepbx ver is 16 with all the updates done. I hope someone will be able to give me a simple solution.

Thanks.

Rob

1 Like

mind sharing relevant sections of the following log file: /var/log/asterisk/full

I had similar “glitch”, don’t recall well, but I think it was on Sangoma P series phones. Firmware update fixed it. I’d check this first. If not, then basic troubleshooting must be done.

Ive had situations where the PBX thinks an extension is busy even if its not (not on DND, no active channels showing in Asterisk), and after messing around with it the fix was to restart asterisk (fwconsole restart). There may have been another way but this is what fixed it.

Thanks Everyone for replying. I’ve sorted the problem after many hours of pulling my hair out. Not a fault with FreePBX. I was using an Cisco spa112 voip adaptor on that extension. I was also messing around with the speaking clock in Freepbx. Well it turns out that the SPA 112 has a menu built in controlled by dialling *xx. To call the speaking clock in free PBX you dial *60. Doing this also makes the spa112 reject the last called number and block it from calling. I have removed this from the menu and everything working again. In the words of Delboy himself What a plonker.

Rob

2 Likes

So, what you’re saying is that you accidentally blocked extension 200 from extension 202 while you were playing around with some *xx codes. Is that correct?

Yes. If you dial *60 the Cisco SPA 112 ATA adapter will block the last called number. *60 is also the speaking clock in Free PBX. So I dialed *60 on extension 202 expecting to get the speaking clock but this blocked extension number 200. It wasn’t until I was logged into the SPA112 I noticed this.

I understand. I was just trying to simplify the answer for the benefit of future visitors to this thread. Someone could easily get lost in all of the details in the explanation.