Tftp not accessable

I’ve been fighting with this for days. My phones wont provision via tftp. It shows tftpd running as a process. I’ve followed the config but the port is still not open from the outside. This is a default install, nothing custom, just a fresh install. I have 2 machines with the same problem. Is there some firewall rule that needs to be cleared first??

Any help would be great.

A little more info on your network would be helpful.

Are the phones on the same network as the FreePBX server?

Are you using DHCP to assign the boot server or did you configure the phones manually?

Have you tried to manually point the phone to the boot server?

Is there a firewall running on the FreePBX box?

I have 2 setups. I ran into tftp problems using a hosted server, so I setup a local box to test first, resolve issue then apply to hosted box. So right now I’m working exclusively on the local box. It gets its Ip manually, and does not have a dhcp server running on it. Currently I have no phones connected to the box. I’m trying to just get the tftp server to respond. Locally on the FreePBX box I can tftp into itself it by using tftp localhost and it works.

Any other box on my local network cannot see the tftp port being open. Therefor will not allow the polycom or aastra phones I have provision.

Greatly appreciate your help.

Also, This is a fresh install. So only firewall that would be running is whatever defaults on a new install. I’ve tried running “service iptables stop” and testing if the tftp port opens up, but it does not.

[[email protected] /]# nmap -sU localhost

Starting Nmap 4.11 ( http://www.insecure.org/nmap/ ) at 2012-04-22 09:20 EDT
Interesting ports on aavfreepbx01 (127.0.0.1):
Not shown: 1480 closed ports
PORT STATE SERVICE
53/udp open|filtered domain
69/udp open|filtered tftp
111/udp open|filtered rpcbind
123/udp open|filtered ntp
672/udp open|filtered unknown
675/udp open|filtered unknown
5060/udp open|filtered sip

Nmap finished: 1 IP address (1 host up) scanned in 1.282 seconds

There is no firewall on or configured in the FreePBX Distro by default.

What version of the Distro are you using?

Can you do a tcpdump port tftp and reboot a phone. Than copy the details of the dump in this post.

If you dont see any results from the dump than your phone is not configured correct or you have something screwed up on the tftp server.

I’m unable to see any logs or connection attempts to the TFTP server. I see no indication of Firewall settings to prevent the connection from happening.

Anyone been able to resolve this issue as to why a remove phone is unable to connect to the TFTP server? All configurations on the Cisco 7940 are correct, since phone can connect to another TFTP server without a problem.

Freepbx insalled was a fresh installation and all default settings.

I’m not clear on why you think that your TFTP port is closed. I’m running an older version of the Distro and am able to provision my phones via TFTP. I ran the same command you used, i.e. nmap -sU localhost, and got the same result:

69/udp open|filtered tftp

This seems to me to say that port 69 is “open” for tftp. I’m not sure what “filtered” means, but whatever it is, it doesn’t impact my ability to provision phones via tftp. I use Aastra phones. I place my configuration files (aastra.cfg and mac.cfg) in /tftpboot.

So, basically, whatever it is about the nmap results that you think are showing a problem aren’t, and you’re on the wrong track.

  1. Make sure your configuration files are in /tftpboot
  2. Make sure your phones are configured to point to the IP address of your system and to use TFTP (and not http or ftp).