TFTP Issues

Hi There,

I am running my first install of the FreePBX Distro and I am having some problems with the TFTP Server.

When using grep tftp /var/log/messages

I see


Oct 13 12:00:04 localhost xinetd[3817]: START: tftp pid=16717 from=127.0.0.1
Oct 13 12:15:04 localhost xinetd[3817]: EXIT: tftp status=0 pid=16717 duration=9                                                          00(sec)
Oct 13 13:08:07 localhost xinetd[3817]: START: tftp pid=21854 from=192.168.1.155
Oct 13 13:18:57 localhost xinetd[3817]: readjusting service tftp
Oct 13 13:38:36 localhost xinetd[3817]: EXIT: tftp status=0 pid=21854 duration=1                                                          829(sec)
Oct 13 13:43:12 localhost xinetd[3817]: readjusting service tftp
Oct 13 13:45:55 localhost xinetd[3817]: service tftp deactivated
Oct 13 13:45:55 localhost xinetd[3817]: tftp: svc_release with 0 count
Oct 13 13:47:38 localhost xinetd[3817]: bind failed (Address already in use (err                                                          no = 98)). service = tftp
Oct 13 13:47:38 localhost xinetd[3817]: Service tftp failed to start and is deac                                                          tivated.
Oct 13 14:00:42 localhost xinetd[3817]: bind failed (Address already in use (err                                                          no = 98)). service = tftp
Oct 13 14:00:42 localhost xinetd[3817]: Service tftp failed to start and is deac                                                          tivated.
Oct 13 15:05:55 localhost xinetd[32679]: bind failed (Address already in use (er                                                          rno = 98)). service = tftp
Oct 13 15:05:55 localhost xinetd[32679]: Service tftp failed to start and is dea                                                          ctivated.
Oct 13 15:14:15 localhost in.tftpd[885]: Unknown option: /tftpboot
Oct 13 15:15:06 localhost in.tftpd[939]: Unknown option: /tftpboot
Oct 13 15:16:54 localhost in.tftpd[947]: Unknown option: /tftpboot
Oct 13 15:16:59 localhost xinetd[32679]: bind failed (Address already in use (er                                                          rno = 98)). service = tftp
Oct 13 15:16:59 localhost xinetd[32679]: Service tftp failed to start and is dea                                                          ctivated.
Oct 13 15:22:23 localhost xinetd[984]: bind failed (Address already in use (errn                                                          o = 98)). service = tftp
Oct 13 15:22:23 localhost xinetd[984]: Service tftp failed to start and is deact                                                          ivated.
Oct 13 15:27:36 localhost xinetd[1014]: bind failed (Address already in use (err                                                          no = 98)). service = tftp
Oct 13 15:27:36 localhost xinetd[1014]: Service tftp failed to start and is deac                                                          tivated.

I tried to re-install the tfpt server but it says it’s already installed.

From the advice of another forum I ran this command:

192.168.1.124 is the ip of my install

When I run netstat --proto=inet,inet6 -pnl

I see:

Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address               Foreign Address             State       PID/Program name
tcp        0      0 0.0.0.0:928                 0.0.0.0:*                   LISTEN      2866/rpc.statd
tcp        0      0 0.0.0.0:3306                0.0.0.0:*                   LISTEN      3920/mysqld
tcp        0      0 0.0.0.0:5038                0.0.0.0:*                   LISTEN      4072/asterisk
tcp        0      0 0.0.0.0:111                 0.0.0.0:*                   LISTEN      2817/portmap
tcp        0      0 0.0.0.0:53                  0.0.0.0:*                   LISTEN      4335/dnsmasq
tcp        0      0 0.0.0.0:22                  0.0.0.0:*                   LISTEN      3801/sshd
tcp        0      0 127.0.0.1:25                0.0.0.0:*                   LISTEN      3992/master
tcp        0      0 :::50000                    :::*                        LISTEN      4275/java
tcp        0      0 :::80                       :::*                        LISTEN      4021/httpd
tcp        0      0 :::50001                    :::*                        LISTEN      4275/java
tcp        0      0 :::50002                    :::*                        LISTEN      4275/java
tcp        0      0 :::50003                    :::*                        LISTEN      4275/java
tcp        0      0 :::53                       :::*                        LISTEN      4335/dnsmasq
tcp        0      0 :::22                       :::*                        LISTEN      3801/sshd
udp        0      0 0.0.0.0:922                 0.0.0.0:*                               2866/rpc.statd
udp        0      0 0.0.0.0:925                 0.0.0.0:*                               2866/rpc.statd
udp        0      0 0.0.0.0:53                  0.0.0.0:*                               4335/dnsmasq
udp        0      0 0.0.0.0:5060                0.0.0.0:*                               4072/asterisk
udp        0      0 0.0.0.0:69                  0.0.0.0:*                               3817/xinetd
udp        0      0 0.0.0.0:4569                0.0.0.0:*                               4072/asterisk
udp        0      0 0.0.0.0:111                 0.0.0.0:*                               2817/portmap
udp        0      0 192.168.1.124:123           0.0.0.0:*                               3833/ntpd
udp        0      0 127.0.0.1:123               0.0.0.0:*                               3833/ntpd
udp        0      0 0.0.0.0:123                 0.0.0.0:*                               3833/ntpd
udp        0      0 :::53                       :::*                                    4335/dnsmasq
udp        0      0 fe80::2e0:4dff:fe1a:102:123 :::*                                    3833/ntpd
udp        0      0 ::1:123                     :::*                                    3833/ntpd
udp        0      0 :::123                      :::*                                    3833/ntpd

I am not a Linux person, so I might be causing more harm than good. I just want to get my TFTP server back operational.

Thanks

Ok, first I fixed your code tags, you can use HTML or BBCODE, not BBCODE in HTML tags. BBCODE uses brackets not carats. Notice how your columns are all straight and readable? Before it was near impossible to read the netstat.

I do appreciate the effort so you get a more detailed response (effort is greatly awarded!)

/usr/sbin/in.tftpd -l -a 192.168.1.124:69 -c -s /tftpboot

First run this command to see if tftp is running:

[[email protected] ~]# ps aux | grep -i tftp
root      8068  0.0  0.0   4004   660 pts/0    R+   21:10   0:00 grep -i tftp
root     24810  0.0  0.0   2204   640 ?        Ss   Oct04   0:06 in.tftpd -v -s /tftpboot
[[email protected] ~]#

Then run this command to show me your tftp config.

[email protected] ~]# cat /etc/xinetd.d/tftp
# default: off
# description: The tftp server serves files using the trivial file transfer \
# protocol.  The tftp protocol is often used to boot diskless \
# workstations, download configuration files to network-aware printers, \
# and to start the installation process for some operating systems.
service tftp
{
 socket_type   = dgram
 protocol   = udp
 wait    = yes
 user    = root
 server   = /usr/sbin/in.tftpd
 server_args   =  -v -s /tftpboot
 disable    = no
 per_source  = 11
 cps     = 100 2
 flags    = IPv4
}

Please post output off both and we will go to next step.

OK, when I run: ps aux | grep -i tftp

I see:


root      9291  0.0  0.0  61208   816 pts/0    S+   19:39   0:00 grep -i tftp

When I run cat /etc/xinetd.d/tftp

I see:

# default: off
# description: The tftp server serves files using the trivial file transfer \
#       protocol.  The tftp protocol is often used to boot diskless \
#       workstations, download configuration files to network-aware printers, \
#       and to start the installation process for some operating systems.
service tftp
{
        disable = no
        socket_type             = dgram
        protocol                = udp
        wait                    = yes
        user                    = root
        server                  = /usr/sbin/in.tftpd
        server_args             = -s /tftpboot
        per_source              = 11
        cps                     = 100 2
        flags                   = IPv4
}

Ok, so we know it’s not running.

Run ‘service xinedt stop’ ‘service xinitd start’ ‘tail /var/log/messages’ and send the output.

Thanks for reviewing things for me.

[[email protected] ~]# service xinedt stop

gives me:

xinedt: unrecognized service

[[email protected] ~]# service xinitd start

gives me:

xinitd: unrecognized service

[[email protected] ~]# tail /var/log/messages

gives me:

Oct 14 04:02:08 localhost syslogd 1.4.1: restart.

Scott had a type

To restart the service type

/etc/init.d/xinetd restart

/etc/init.d/xinetd restart

gives me:

[[email protected] ~]# /etc/init.d/xinetd restart
Stopping xinetd:                                           [  OK  ]
Starting xinetd:                                           [  OK  ]

tail /var/log/messages

now gives me:

Oct 14 04:02:08 localhost syslogd 1.4.1: restart.
Oct 14 15:44:38 localhost xinetd[3820]: Exiting...
Oct 14 15:44:38 localhost xinetd[18412]: xinetd Version 2.3.14 started with libwrap loadavg labeled-networking options compiled in.
Oct 14 15:44:38 localhost xinetd[18412]: Started working: 1 available service

Ok, how about running the ps aux | grep -i tftp again? Is it running?

I get the feeling you are just typing commands and not understanding any of this.

You are following my steps literally and not taking any leaps.

Anyway, edit your cat /etc/xinetd.d/tftp, look at mine, take out the disable line and add the verbosity flag (the -v) to the start arguments so we get more info than the messages.

Restart the service again (you can do Tony’s way or ‘service xinetd restart’ (both work) and then tail out your system messages file.

On the off chance it’s disable in the config file do a ‘cat /etc/xinetd.conf’

i solved my problem with
a addition to the dhcpd.conf

subnet 192.168.71.0 netmask 255.255.255.0 {
next-server 192.168.71.1;
option routers 192.168.71.1;
—> option tftp-server-name “192.168.71.1”; <---------
option subnet-mask 255.255.255.0;

Hi
i am using freePbx and now i got a number from service provider they configure this number in Alcatel-Lucent device with some IP and TFTP that i can see in Alcatel-Lucent device can i configure this alcatel setting in my pbx to receive all in pbx. i have ip,subnet.tftpserver.port, so plz let me know what is the method to connect it.