Text to Speech creation

I’ve typed in some new text to use for a Voicemail greeting selected the engine (flite) and clicked on submit the Apply Config, but the message doesn’t replace the default of the messege I selected to be saved.

So what have I missed and also can I save messages without having to overwrite a default message?

Also later I’ll want to upload some messages to use that I’ll grab from our legacy analogue PBX, so how do I do that?

Settings → Voicemail Admin → Settings → Soundfiles

Voicemail Admin - Advanced Settings - PBX GUI - Documentation (freepbx.org)

But there is nothing there for Busy, Unavailable etc


What makes you think this is going to put a specific greeting in a specific mailbox?

I’d hope to have the generated or uploaded message available in the drop down here to select it.

This is not a function you can use the Text to Speech engine for as it doesn’t actually create any files. It does real-time read back of the text you’ve entered when you send a call to the STT destination.

So I should get this text read out when a call is routed to [Voicemail: 22 Holtain Office (Unavailable Message)], however I still get the system default message, so I’m doing something wrong.

Yes. I told you, you cannot use this for that. The greeting is played by the voicemail application which cannot use the TTS engine.

So how do I change the voicemail greetings from the default?

You call into the voicemail system and follow the instructions to create a greeting?

Or you manually upload each recording to each existing or new mailbox folder location on the system.

The last thing I want is a greeting with my voice, Do I upload them with the user control panel?

I am not super familiar with the UCP as I don’t really use it all that often so maybe the documentation has the answer for you.


However you can manually upload the files to each mailbox directory as needed. They are located in /var/spool/asterisk/voicemail/default/< extension >.

We’re definitely making progress, I can play an uploaded mesage but I do still get the last part of the default greeting Starting “Please leave your message after the tone…”

And I think I’ve found the magic to disable it.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.