TE110 T1 loop clock with Asterisknow & free pbx GUI


I have set up a Asterisknow 3 system. In this system i have installed a TE110 T1 card.

The t1 needs to be in “loop clock” mode as it only has one T1.

The GUI the came with the Asterisknow only gives a choice of 0 and the 0 appears to be “internal clock”

upon reading I think I need to edit the system.conf, however it says not to do that and refers me to a web page. However i can not find any guidance for fixing this issue.

any help greatly appreciated.


I’m not familiar with a “loop clock” on a T1 but I have configured some T1 circuits and PRI circuits for Asterisk use. In either case they need a “clock” or timing source, and that is configured in /etc/dahdi/system.conf, generally by the dahdi_genconf line command which will set the standard defaults depending on what it detects hardware-wise.
A T1 or as I think of them “one-way” bulk digital circuits with no data channel, has a line in the system.conf that defines the “span” including the clock source, usually that is the carrier unless you are connecting your Asterisk system to another PBX and want it to act as the carrier. Here is a good link from a smart guy (Eugene Blanchard) that covers it really well; http://www.cadvision.com/blanchas/Asterisk/ConfiguringT1LineDahdi.html

The only other knowledge I have of something to do with a T1 and “loop” is a loop back plug that makes a T1 (or PRI) connect to itself for testing. Here are instructions for making one:

Good luck!

Loop is another term for time off the span or line.

Thank you for responding.

While I am very new to FreePBX and Asterisk I started working on T1’s in the late 70’s. I was Voitek / Datek with Telco before deregulation and thus changing careers.

A T1 is a synchronous service. In it basic form lets say 2 channel banks talking to each other one will provide the clock, and the other must lock to that clock.
I have seen many different ways of describing this relationship. Master / slave, Internal / loop and many others. Sorry if I was not using the current terminology.

Now with respect to a switch, they must also be in time with each other else the results are frame slips.

the Class 1 C.O. was the master clock and moving down to the Class 5 C.O. (the local co) was receiving the Class 1 clock via the Class 2,3,4 C.O…

Thus all C.O.'s where in time with each other.

Then the PBX in this case FreePBX (Asterisk) must be loop clocked to the TELCO.

The only setting available in the FreePBX GUI was for the Asterisk to generate it’s own clock. This causes frame slips.

I did figure out that in the /etc/dahdi/system.conf
span=1,0,0,ESF,B8ZS = internal clock
span=1,1,0,ESF,B8ZS = loop clock

There is only one choice in the GUI, internal clock.
I edited the /etc/dahdi/system.conf as a test and it does resolve the problem, however the instructions say not to edit that file, and it refers me to a web page.

Unfortunately it did not cover (or I missed it)how to properly make a manual edit that will keep the system happy.

Hopefully this bug can be fixed, but it will probably take a long time.

until then I need guidance on how to correctly make this change.

Any help greatly appreciated.


Yep, you understand North American Digital Hierarchy. You would have gotten a gold start if you would have used plesiochronous in your description.

Anyway enough of the mutual admiration society. I don’t know anything about this module. I assume there is a way to make customization’s. Have you looked in the wiki?

Open a ticket on this issue.

Thank you the in the conf file it refers me there however it covers many other changes not this one.

I am very new to asterisk, and this one has me stumped. ( as I progress I am sure other issues will stump me as well)