TDM400P not working? [SOLVED]

Hi Forum

Long story short.
We been using FreePBX 6.12 for some years.
Just suffered hard disk failure. (Need to pay more attention to warning signs.)
Rebuilt FreePBX with new HDD (WD Enterprise grade)
Applied all updates to latest.
Restored FreePBX from backup (mostly worked).

BUT can’t get Digium TDM400 analog card working.

Hardware is detected by lspci
01:06.0 Network controller: Tiger Jet Network Inc. Tiger3XX Modem/ISDN interface

Hardware is detected by dahdi_hardware
pci:0000:01:06.0 wctdm- e159:0001 Wildcard TDM400P REV I

Dahdi kernel modules are loaded, lsmod | grep dahdi
dahdi_transcode 6697 1 wctc4xxp
dahdi_voicebus 54834 2 wctdm24xxp,wcte12xp
dahdi 224730 18 xpp,dahdi_transcode,wcb4xxp,rcbfx,wctdm,wcfxo,wcaxx,wctdm24xxp,rxt1,r1t1,wcte11xp,wct1xxp,wcte13xp,wcte12xp,dahdi_voicebus,wcte43x,wct4xxp,oct612x
crc_ccitt 1717 2 wctdm24xxp,dahdi

Further investigation reveals the following :
Empty configuration – no spans
Empty configuration – no spans
Empty configuration – no spans

dmesg | grep dahdi
dahdi: Version:
dahdi: Telephony Interface Registered on major 196
dahdi: Warning: Span WCTDM/4 didn’t specify a spantype. Please fix driver!
dahdi: disable_span: span 1
dahdi_transcode: Loaded.

Please for any advice to get this Digium card working.
Do I need some other driver/s ?

First off make sure


is not “helping” you, Also make sure that any FXO interfaces have “battery” present. Also you need to have the molex connected for the FXS’s to be recognized fully, add -v to your dahdi calls.

Hey dicko, thx for helping

To be sure, I’ve renamed /etc/dahdi/genconf_parameters as …/genconf_parameters.original
Not sure what you mean by “battery” in FXO interfaces.
I understand that FXO interface receives “battery” current from the local telco exchange. Yes, I have the FXO port connected to the telco exchange line.
Yes, I have molex power applied, but NO FXS ports connected.
All FreePBX extensions are VOIP and working as intended !

Can you restre your old /etc/dahdi directory from any backup you made?

Unfortunately, that is looking unlikely. I’m still searching, hoping, wishing, dreaming.

Edit. When restoring from the FreeBPX backup, I ticked the box for “etc”, but maybe that means somethings else.


Searching other fora gave me clue to possible hardware issue.
After re-seating the TDM400P in PCI slot, it seems the dahdi driver/s might now be working correctly.
We’ve moved on to next problem with Asterisk Manager.

Unable to connect to Asterisk Manager from /var/lib/asterisk/bin/retrieve_conf, aborting

It looks hardware issue. Make sure you plug the 12V power supply cale if you have FXS on the board. The system has detected the main board, the daught cards missed. maybe you take out the fxs or fxo module and clean agagin and have a try.

1 Like

Yeah. the problem was eventually solved by re-seating the TDM400P in a different PCI slot.
Maybe the same slot would have worked. No matter. [SOLVED]