FreePBX | Register | Issues | Wiki | Portal | Support

TC400 Series compression card


(Omarioja) #1

Good day all, i have a TC400 Series compression card install on my freePBX. To make sure the card was installed i ran the following command < transcoder show > i got the following results.

0/0 encoders/decoders of 92 channels are in use
Could someone explain what this means?
Also how do i know that the card is doing that its supposed to do?
How would i configure my end points to make the best of the features of this card?

Thanks.


#2

It means that the card is configured for mixed-mode, whereby it can handle G.729a and/or G.723.1 for each of 92 channels. And, that at the present time, (0 encoders and/or 0 decoders) it wasn’t being asked to handle any transcoding.

If the card wasn’t detected, you would have seen:

No DAHDI transcoders found.

so, that’s all good and well.

When the card is being exercised, you’ll see those numbers change.

The card gets exercised when an endpoint shows up requesting either of the G.729a or G.723.1 codecs and Asterisk needs to transcode.


(Omarioja) #3

Thanks, now i have a better understanding. How would i change the mode from g723 to g729?


#4

The card can do 92 channels of either G.729a or G.723.1. Or, the card can do 120 channels of G.729a only. This is determined by the module parameter mode. The mode module parameter may be set in /etc/modprobe.d/dahdi.conf for the wctc4xxp module, as described on page 29 of:


(Omarioja) #5

Thanks. I went through this already. i dont manage asterisk from the command line i use Freepbx GUI. I need to know how to set the card to used G.729a from the freePBX interface. When i try to modify the file from the command line it says withing the file that i need to do it from the web interface.


(Omarioja) #6

Hey i figured it out. thanks for your feedback.
Asterisk SIP Settings module and scroll down until you see the Codecs section