T.38 Gateway for Digium/Sangoma FXS Ports?

We have finally gotten T.38 working reliably with Adtran 900-Series and Linksys SPA-2102’s and Asterisk with Super-G-Everything FAX machines - Inbound and Outbound work perfectly with any combination of remote receiver/sender - reception straight into Asterisk has been working reliably for years.

We had given up on T.38, but tried again a few months ago because we were trying to use the Adtran’s for a large Analog deployment and tried a FAX machine as an afterthought - it worked perfectly for the first time, and we got excited about Adtran.

Then on a hunch, I tried a Linksys SPA-2102 we had laying around (we have LOTS of them laying around because we quit trying to use them) and it also worked perfectly.

So it looks like Asterisk 11 is now correctly doing T.38 to at least the Adtran and Linksys ATA’s and that this is now usable and deploy-able. We switched a Medical Practice with 8 Super-G3 FAX Machines used for both Inbound and Outbound and they are working without a hitch.

Then I looked at my huge pile of TDM-410’s and A-200’s and thought hey - T.38 Gateway is supposed to work in Asterisk 11 now, so I set up a box and tried both the 410’s and the 200’s - The handshake works, but they fail on send and receive with retry errors exceeding the allowed threshold.

Does anyone know if T.38 Gateway is supposed to work with Digium/Sangoma FXS ports? Everything I have read suggests that it should, but testing says otherwise.

Hi Greg!

Were you finally able to get it to work or does anyone know if what Greg wants to do is doable?

What I have seen on the subject also suggests it should work…

Thank you and have a nice day!


As far as I know it still doesn’t work - I would like to try it again with Asterisk 13, but we use a Broadsoft SIP trunking provider and we are getting audio dropouts on their trunks using 13 and Chan-SIP and I have been unable to get Chan-PJSIP working with my trunks - works fine with the phones.

It’s weird because it seems so obvious that it should work, but whatever the magic combo is, I can’t find it.

Hi Greg!

I tried a few things the last few days but it still doesn’t work on my side…

I tried activating the T.38 gateway mode which is apparently needed to get this working by activating the T.38 gateway at the trunk level.

(By adding setvar=FAXOPT(gateway)=yes to the trunk definition, I read you could do that…)

The provider I tried this with is Flowroute which does support T.38 (and very well for inbound faxes directly processed by Asterisk).

I don’t have access to my logs right now but the messages I got suggested that T.38 was either used or at least attempted.

However, I keep on getting “RTP Read too short”.

Sangoma’s documentation on their wiki says that doing this with FreeSwitch (which, if I read right uses spandsp as well) is supposed to work.

Re: http://wiki.sangoma.com/wanpipe-freeswitch-config-appendix#t38

Clearly it seems it’s not a limitation of the Sangoma A200 but either an Asterisk or FreePBX limitation/issue.

If I find something else I will let you know…

Have a nice day!


RTP Read Too Short is caused by a mismatch in the MaxDatagram setting - Here is what I found works for me most of the time:


But play with it - I have had so use as little as 128 and as much as 600.