System Recordings GUI not converting

In the GUI, under System Recordings, when I try to upload an MP3 or WAV and convert to ANY file format (I’ve tried ALAW, ULAW, WAV, etc) Uploading just the MP3 with no conversion works, but when assigned to the IVR, nothing is played when a call is placed.

The responses from Ajax.php are:

then subsequently:
{“status”:false,“message”:“File was not converted [/var/lib/asterisk/sounds/1pp-ivr-intro3-mp3-1454542355230.mp3.alaw]”}

I am on the latest version, patch set 7, running on the FreePBX AMI in Amazon AWS. I sort of expected everything to work out of the box, but maybe there is a something I am supposed to do?

Any help would be greatly appreciated.

What version of Asterisk?

cat /etc/asterisk/version shows 13.1.0

We are up to 13.7 now. I suggest you try updating

Interesting - I installed from the latest AWS AMI available, and ran the 10.13.66/ upgrade script

What is the recommended way to update asterisk? I tried with yum update asterisk13 before and it caused a bunch of permission issues.

Is there a better way?


I presume the AWS AMI is not configured properly, I get: command not found

Is this the FreePBX distro? Firstly not sure how you got the distro installed on AWS. That is not something we support. If you are missing commands such as “asterisk-version-switch” then there are bigger problems

I purchased paid support from Sangoma/Schmooze, my ticket has been open since last week with no reply, I was trying to get some support from here, as you guys seem more responsive.

The AWS AMI is at https aws DOT

What is your ticket number?

Again. We don’t support AWS. We also don’t make the AMI, an external party does.

I understand that it is not made by you guys, but its all running essentially the same software, but this is why I paid for support, knowing that it would take a more close look.

My ticket # is 415773

Seems your issue is with a corrupt Asterisk. You need to at least try to get to Asterisk 13.7. Yum update should have worked too, but if you are having permission errors that only further confirms there are problems with this AMI image.

Well when I run: yum list installed | less, I see 13.7.0 installed, but when I do cat /etc/asterisk/version I see 13.1.0

So I guess FreePBX is connected to the older installed version?

After I had run the yum update, the FreePBX GUI said “Cannot connect to Asterisk”, I fixed this by running the latest update to the 10.13.66-7 build, as that script updates all the permissions.

However, without asterisk-version-switch, I am not sure how to change the mappings to the latest version - this is where I hoped to get help from the paid support, and if paid support was unable to help because of lack of support, I’ll need a refund of my $150

I was able to located asterisk-version-switch and executed that, after it completed, reset everything, ran module updates and now the system recordings are working.

Thank you for helping guide me to fixing the problem.

Also - note that cat /etc/asterisk/version still says 13.1.0… not sure why, but it is all working now.

Is there anywhere else to tell the version that may be more accurate?

This is the base install. It doesn’t mean the current install. You could have figured out the current install by running asterisk -rvvvvvv[quote=“1parkplace, post:13, topic:33108”]
I’ll need a refund of my $150

As part of the TOS you agreed to we do not provide refunds