SYSTEM DOWN - Any Help Appreciated

Asterisk/FreePBX 14


When doing a standard reboot of one of our main servers (Admin>System Admin>Power Options> Reboot), rebooted, came back up except for the GUI. I am getting the following error:

Exception: SQLSTATE[HY000] [1045] Access denied for user 'freepbxuser'@'localhos                                                                                                                                                             t' (using password: YES)::SQLSTATE[HY000] [1045] Access denied for user 'freepbx                                                                                                                                                             user'@'localhost' (using password: YES) in file /var/www/html/admin/libraries/ut                                                                                                                                                             ility.functions.php on line 204
Stack trace:
  1. Exception->() /var/www/html/admin/libraries/utility.functions.php:204
  2. die_freepbx() /var/www/html/admin/libraries/BMO/Database.class.php:145
  3. PDOException->() /var/www/html/admin/libraries/BMO/Database.class.php:140
  4. PDO->__construct() /var/www/html/admin/libraries/BMO/Database.class.php:140
  5. FreePBX\Database->__construct() /var/www/html/admin/libraries/BMO/FreePBX.c                                                                                                                                                             lass.php:71
  6. FreePBX->__construct() /var/www/html/admin/bootstrap.php:153
  7. require_once() /etc/freepbx.conf:9
  8. include_once() /var/lib/asterisk/bin/fwconsole:12

It seems the freepbxuser user cannot login with YES , even though that was never the password and is not the password in the /etc/frepbx.conf file ($amp_conf[‘AMPDBPASS’] ).

I thought I had this come up once before, and solved it with:
update freepbx_settings SET value = ‘’ WHERE value = ‘[Old Password]’;

I also tried a solution from @cynjut:
update user set password = password('thepasswordyouwanttouse') where user = 'freepbxuser';

I have tried to set the password to: ‘’, ‘YES’, ‘[The password in freepbx.conf]’

nothing is working unfortunately, and we will start to see bigger impacts in the morning. Does anyone have any guidance they can help with? It seems like a straightforward issue. Thanks in advance!

Also seeing this in the CLI notes:
[2020-10-29 22:14:02] WARNING[12647]: res_odbc.c:1075 odbc_obj_connect: res_odbc: Error SQLConnect=-1 errno=1045 [unixODBC][MySQL][ODBC 5.2(w) Driver]Access denied for user 'freepbxuser'@'localhost' (using passwo

I wonder if it is because I cannot fwconsole reload?

The error you’re getting is from Mariadb/Mysql.

I ran into a problem like this (in a completely different context, but similar) where I upgraded the database server and the “upgrade” script for the server reset all of the password to “ThisPasswordIsNotValid” (or something like that) for any password that was less than 8 characters or were considered “too easy”. One of them was the ‘root’ password, so that was a little exciting.

I had to add to start mysqld_safe with the option “–skip-grant-tables” to get logged in (bypass the root user). With this option set, any of the ‘normal’ ways of dealing with passwords were disabled, but I was able to use the command "update user set = password(‘password’) where user = ‘asteriskuser’.

Now, this is in a new version of mysql, so this might not solve your problem, but the “–skip-grant-tables” was the part that fixed it for me Sunday.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.