System Admin module version 16.0.57 or higher is required, you have 16.0.23

I have upgraded from Version 15 to Version 16.0.21.9. I get error: Module disabled on ExtensionRoutes. Missing Requirements System Admin module version 16.0.57 or higher is required, you have 16.0.23

I have checked the repo and 16.0.57 is not available. Any suggestions?

Hi @yaseentayob

The issue is fixed with extensionroutes v16.0.7. Please upgrade the same and check.

Thank you.

In module admin, extension routes is disabled and cannot be upgraded. If i try from console i get the following

fwconsole ma downloadinstall extensionroutes
No repos specified, using: [standard,extended,unsupported,commercial] from last GUI settings

Downloading module ‘extensionroutes’
Processing extensionroutes
Verifying local module download…Verified
Extracting…Done
Download completed in 5 seconds
Detected Missing Dependency of: sysadmin 16.0.57
Downloading Missing Dependency of: sysadmin 16.0.57
Processing sysadmin
Verifying local module download…Verified
Extracting…Done
Module sysadmin successfully downloaded
Installing Missing Dependency of: sysadmin 16.0.57
Updating tables sysadmin_options, sysadmin_update_log, sysadmin_fail2ban…Done
Sangoma PnP Server activated
Generating CSS…Done
Installed Missing Dependency of: sysadmin 16.0.57
Dependency module sysadmin version 16.0.57 is Enabled
Unable to install module extensionroutes:

  • System Admin module version 16.0.57 or higher is required, y ou have 16.0.23
    Updating Hooks…Done
    Chowning directories…Done

Hi @yaseentayob

Please run “fwconsole ma downloadinstall extensionroutes --tag 16.0.7” from command line and the issue should be resolved.

I have run the command and get the following

fwconsole ma downloadinstall extensionroutes --tag 16.0.7
No repos specified, using: [standard,extended,unsupported,commercial] from last GUI settings

Unable to update module extensionroutes - 16.0.7, it does not exist:
Updating Hooks…Done
Chowning directories…Done

Hi @yaseentayob What is the output of below command ?

fwconsole setting MODULE_REPO

If it is not the correct repo then you can set it by specifying.

fwconsole setting MODULE_REPO https://mirror.freepbx.org

Thanks

HI, The repo is correctly set to https://mirror.freepbx.org

fwconsole setting MODULE_REPO

Setting of “MODULE_REPO” is (text)[https://mirror.freepbx.org]

Do you have a paid license for Extension Routes? If so, open a support ticket. If not you can just delete the module and proceed.