System Admin module DDNS BAD Resolve

I have been using the System-admin payment module and its DDNS service for several years.

The problem I have is that although the administration page shows me the current public IP correctly, if I ping 9427xxxxx.deployments.pbxact(dot)com I get a different IP, and therefore I can not access from the outside, but if I put the ip directly if I can.

I have tried to force the ip in the module options, but it keeps responding to a different IP.
No settings have been changed.

Have you checked the Sangoma portal reflects the correct IP? The module should sync with the portal if memory serves.

I think I have seen it where the portal hasn’t got the correct IP from the PBX.

Yes i checked the ip on portal.samgoma(dot)com and the ip that it shows me is correct but instead if I ping the ddns url that it gives me, I get a different one.

Hi @Vandark
Looks like your LAN DNS cash is not correct. Try to clean your DNS cash and add additional Public DNS such as Google DNS( ; )

The DNS on PBX its and
On router same
if make ping on another server to the ddns url the url continue bad

could you pls pass here, your PBX /etc/resolve.conf file and screenshot of SystemAdmin → DNS

Your images.

The DDNS Shows the IP but 94275417(dot)deployments(dot)pbxact(dot)com resolve other

Is your PBX all modules are up to date ?
fwconsole ma refreshsignatures
fwconsole ma showupgrade
fwconsole ma upgradeall

Updating Hooks…Done
[[email protected]_PBX etc]# fwconsole ma showupgrade
No repos specified, using: [standard] from last GUI settings

Up to date.
[[email protected]_PBX etc]# fwconsole ma upgradeall
No repos specified, using: [standard] from last GUI settings

Up to date.
Updating Hooks…Done

i can see like that

# dig

; <<>> DiG 9.11.4-P2-RedHat-9.11.4-16.P2.el7_8.6 <<>>
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 58389
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

; EDNS: version: 0, flags:; udp: 1232
; IN    A


;; Query time: 14 msec
;; WHEN: Wed Jan 05 11:28:49 UTC 2022
;; MSG SIZE  rcvd: 76

[[email protected]_PBX etc]# curl checkip(dot)amazonaws(dot)com

I think you have some unpaid license OR expired license. Is your system FreePBX or PBXact?
pls check your PBX License number:

fwconsole sa info
fwconsole sa u

Also if your PBX is System 13 ( FreePBX-13 ) then you need to contact with Sangoma Support Team… Could be System-13 is EOL


The problem continue…

Open Sangoma Support ticket for Billing and License Department. I think we can NOT to do nothing from here…
How to you see on your screenshot its says FreePBX Distro and PBXact which information is correct :slight_smile: PBXAct or FreePBX ?

I think Sangoma Support Guys knows your issue… Call them.



I have had this problem before, had to contact Sangoma support. Ended up being something on their end, that they fixed rather quickly.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.