System Admin license updates not applying

Hello all. I’m wondering if some changes have been made in the past year to the formatting of the license info that is sent to the FreePBX server when a user clicks the button in System Admin to check for license updates. I have an old box ( that the customer hasn’t the budget to replace yet. They use Extension Routing commercial module on an annual basis. It just expired & has been renewed in the sangoma partner portal & correctly assigned to their deployment ID. Upon clicking the button in FreePBX System Admin to check for license updates, it always comes back still showing the Extension Routing license is expired. I have restarted apache, as this is supposed to sometimes cause this to be cached. To no avail.

Interestingly watching a tcpdump on the customer’s firewall, appears as though everything is sent back correctly. This leads me to suspect that maybe Sangoma changed the formatting of how this data is being sent back to the FreePBX box. Because there really haven’t been any changes to this box in the past year, and last year all that was necessary was to stop httpd, then start it. Then the check for license updates worked as expected.

I realize that the right decision here is to force the customer to pay for an upgrade project, and use the online migration tool. I will try to make that happen. In the meantime though, they are still severely impaired. I would really appreciate any help with this.

Here’s the HTTP conversation that occurs between the customer’s FreePBX server & the Sangoma licensing server. I’ve replaced anything sensitive with **************:

FreePBX client request:

POST /license.php HTTP/1.0
Content-Length: 159
Content-type: application/x-www-form-urlencoded


Sangoma server response:

HTTP/1.1 200 OK
date: Tue, 21 Apr 2020 15:41:03 GMT
server: Apache/2.4.38 (Debian)
x-powered-by: PHP/7.3.10
pragma: public
expires: 0
cache-control: must-revalidate, post-check=0, pre-check=0
cache-control: private
content-length: 479
vary: Accept-Encoding
content-type: text/html; charset=UTF-8
connection: close

Hardware-Locked = Yes
Product-Name = PBXact
Registered-To = *****************
branding = FreePBXDistro
deploy_type = OSS
deployment_id = *****************
deploymentid = *****************
distributor = No
extroute_exp = 2021-04-21
global_lic_exp = 2042-02-01
hostid = *****************
license_version = 2
updates = *****************
Expires = 04-Feb-2030
Produced-By = Schmooze Communications
Verification-Code = *****************

Pretty sure licensing for old EOL versions is broken. It’s long past time to get on a supportable version.

1 Like

@lgaetz I agree. Do you know whether the online conversion/migration tool still works with FreePBX 2.11?

tool allows you to take any FreePBX based system that is running version 2.9 or higher

But the current version of FreePBX 15 allow you to restore from a legacy backup. It’s the cleaner option.

@lgaetz s Hyper-V still not supported? We have that at our disposal and could probably rectify this fairly quickly if we could utilize it. Don’t want to mess around with an unsupported scenario though. We’re already there, and it’s not fun. :slight_smile:

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.