Sysadmin pro not forwarding mail properly

Edit: This is delightful, it won’t let me paste maillog output because “new users can’t post links”. It’s not a link?

System installed this past Monday from SNG7-FPBX-64bit-1805-1.iso in a VM under Proxmox. Fully updated to current. Very simple installation for home use/lab, one trunk, 2 extensions for now.

The problem is that voicemail forwarding to an external relay isn’t working. SMTP auth/SSL/SASL is fine and the mail server is accepting the connection, but the email never gets through. I’ve reviewed /var/maillog and the problem is that postfix is not replacing the default [email protected] email address when attempting to send the emails. (I’ve since found the debug button in the UI that shows this log file). Comparing my log to a working example at a client’s office I find that their setup has something like this line every time an email gets sent.

Aug 21 13:47:36 freepbx postfix/smtp[3338]: E417F20E848C: replace: header From: “FreePBX Phone System”

The rest of the line is the “from” email that replaces the default, which the forum won’t let me post. My installation doesn’t do this, and my mail server does not like the default address.

I’m thinking this is an order of install/setup problem. I purchased and installed the sysadmin pro addon prior to configuring notifications in sysadmin, and prior to any other email related config in the system. Speculation aside I’ve made several attempts to change the email settings, notification settings, anything that might trigger the system to regenerate the postfix config with the correct replacement option, and I’ve had no luck.

I have a vague memory of doing this config in some other context, but I generally try to avoid mucking with config files in appliance scenarios like this for fear of my changes getting nuked in an update. Could anyone give me a means to fix this problem?


You will have to manually edit the file under /etc/postfix and change
myhostname and myorigin.

Don’t forget to restart postfix.

This is similar to a bug report I reported some time ago.


Many thanks!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.