Sysadmin not installing


I had tried to install FreePBX 12 (following instructions ), and i can not install sysadmin module…

1.- When i try “amportal a ma install sysadmin” I get:

Please wait…
2.7.0 202.shmz65.1.18
Successfully copied LoadLicenseIfExists.php.
mv: cannot stat `/var/lib/asterisk/agi-bin/license-*.zl’: No such file or directory

And then it freezes and stay until pressing Ctrl+C.

2.- From control panel i can not see “System Admin” Module, and when i go to “Module Admin” and try to install, i get similar output and stays loading forever, until i restart apache. If i look the shell via “amportal a dbug” i keep getting infinite: “(Not all processes could be identified, non-owned process info will not be shown, you would have to be root to see it all.)”

Any ideas how to approach this issue, please? I had seen post Problem to install new sysadmin which seems very similar although different version, but there was no solution on it…

Thank you very much!

It would be easier to install from the Distro.

I have no physical access to the server, so i can not burn a CD… If it can be done via shell access please show me how.

Anyway, it seems something is not going fine if this still happens (and had happened before), and i am sure it will happen to others in the future.


You can follow these instructions:

Hello Preston,

Those instructions in that link are exactly what i tried on point number 2 with no success. As i stated, when i try to install sysadmin from freepbx control panel, the “pop up” window progress gets freeze every single time i tried. I f i do not include sysadmin module just others, everything updates fine; but when i try to install sysadmin gets freeze after echoing “Successfully copied LoadLicenseIfExists.php.”

Since i got no clue after struggling hours with it, i guess will start again from scratch on other server. If the problem reproduces again, i do not know what else to do…