Sysadmin and dependency on sysadmin-2.6.1-151+

So, I have a machine (several, actually) that was originally installed with freepbx distro that has since been upgraded through the module upgrade interface to version 2.11. Because of this, I was prompted tonight to install sysadmin, but that failed, telling me that my sysadmin RPM was not a new enough version, and to install it with “yum install sysadmin”, which I did, however it continues to complain that it is not new enough. yum install ssyadmin of course installed the module from which is sysadmin-2.5.1-1.noarch.rpm. Based on reading the install.php file for the module, it wants at least 2.6.1-151 (current as of this writing is -155)

I have had a pretty good look around, and as far as I can see, the only version that has a version of sysadmin-2.6.1 >= 151 is 2.210.64. Unfortunately, the base OS for that version is CentOS6 vs the CentOS5.7 on my system, and the package will not install due to unmet dependencies. 1.818.210.58, the latest 1.8x.210.5x branch has only 2.6.1-18.

So, having upgraded, due to the failed install, freepbx has disabled the module. As far as I can see, there is no possible way for me to get a version of the RPM that will work on CentOS 5.x that is new enough to work with the version of the module.

So I have 2 questions:
1/ What to do? Reinstalling these machines with a 2.210.64 or 2.11 distro is not a viable immediate option, unfortunately.
2/ With the module disabled, will the basic functionality of the sysadmin module like fail2ban continue to operate properly?

Thanks for any assistance you can provide.

Hi gws, despite the initial conditions seems not to be the same (your system has unmet dependencies and, AFAIK, this generated all the issues you reported) some users are discussing about recent sysadmin Module/RPM update issues here.

Have a look, maybe some developer can help you suggesting what to do in your very specific case.

Question: actually which FreePBX Distro version does your system is running on?

Reading your initial sentence “…that was originally installed with freepbx distro that has since been upgraded through the module upgrade interface to version 2.11.” it’s not really very clear which FreePBX Distro version (not the FreePBX package version) your system is currently running.

I mean, if your system was upgraded to a very recent FreePBX Distro (e.g. FreePBX Distro 4.211.64 (i386)) then repositories shouldn’t point (of course) to what you wrote SO maybe your systems were all still based on FreePBX Distro (which is EoL…) but you were referring to FreePBX modules’ updates and not Distro update.

Lastest sysadmin- introduced a RPM’s version check to ensure the proper RPM is installed in order to permit a correct sysadmin module update (in new system, I add).

Have you tried to revert back to previous sysadmin module you had by removing it and reinstalling it uploading by hand locally? …and, doing so, had you tried to revert back also the RPM at its original version too? This to see if the Developers could find a solution. If any.

I bet another cross check to avoid that module suggests its update IF not only that RPM isn’t at the right version but also IF that RPM could not be effectively receive an update due to FreePBX Distro version be so old, so old that it is no more actively developed as a whole.

The distro is The machine is ~2 years old. FreePBX has been upgraded to 2.11 via the upgrade module offered through the Module Admin interface. If 2.11 is going to supply modules that are not compatible with older platforms like 1.8x.210.5x, then it shouldn’t have offered to upgrade on that platform and should have left me on 2.10. As I said, upgrading the base platform / reinstalling is not something that is in the cards at the moment.

At this point, I kinda need one or the other of two things… either a compatible sysadmin RPM package for CentOS 5, or a way to revert the FreePBX sysadmin module back to (or whatever version is the latest doesn’t require the updated RPM). I guess I’ll go see if I can find an old module tarball and try uploading it by hand. This is already consuming far more of my less than copious time than I had intended when I ran a simple module upgrade.

Unless I’m missing something, this is an issue that is going to affect anyone who has upgraded to FreePBX 2.11 on a distro older than 2.210.64. If they require RPMs that are only compatible with the latest release, when people on older releases can upgrade (through FreePBX’s own module admin interface) to 2.11, that strikes me as a potentially wide-spread serious problem.

FYI: I did not post in that other thread, because the topic of the thread was the web UI breaking because of the upgrade. My issue is strictly version compatibility. Most support forums ask you not to cross post different issues to other people’s threads, hence the separate post. Sorry if that was the wrong choice.

OK I agree with you. The issues are different, I know…but the root cause was the relationship between a module upgrade and the RPM required to comply with that upgrade. So my reference to that other thread.

A note about cross posting:

I never suggested you to do a cross post using the other thread but I wrote you to simply have a look at it because there some developers announced a new released sysadmin module (the if I recall well) which has a (sysadmin) RPM dependency check to prevent (to avoid) what happened to your system.

Please read also this new one post.

Ok to help you guys out I am going to attempt to build a CentOS-5 RPM of sysadmin.

Can you do me a favor and give me the output of

cat /etc/yum.respos.d//etc/yum.repos.d/schmoozecom.repo

I do not have a schoozecom.repo file in my /etc/yum.repos.d. The only repo that is there is FreePBX.repo. In case that’s what you wanted, its contents are below.


If the mirrorlist= does not work for you, as a fall back you can try the

remarked out baseurl= line instead.

name=CentOS-$releasever - Base

#released updates
name=CentOS-$releasever - Updates

#packages used/produced in the build but not released
name=CentOS-$releasever - Addons

#additional packages that may be useful
name=CentOS-$releasever - Extras

#additional packages that extend functionality of existing packages
name=CentOS-$releasever - Plus

#Core PBX Packages

Just to add, I’m fine with downloading the RPM manually from somewhere and installing it from the shell. It doesn’t have to be yum installable. Thanks for the taking the time to try and fix this up for Cent5, Tony. I appreciate it.

Please wait while module actions are performed
Downloading sysadmin 156692 of 166137 (94%)

Just stops there and this is the second time we have tried