Symlink error after module updates

We had a legacy 1.817.210.58-1 system suddenly pop with about 30 module updates today. Was going to wait to install them but after the active exploit notice today we went ahead and installed them. Now we’re seeing this in the Notices:

retrieve_conf failed to sym link:
/etc/asterisk/logger.conf from core/etc (Already exists, linked to something else)
This can result in FATAL failures to your PBX. If the target file exists and not identical, the symlink will not occur and you should rename the target file to allow the automatic sym link to occur and remove this error, unless this is an intentional customization.
Added 2 hours, 9 minutes ago
(retrieve_conf.SYMLINK)

The system is running, but the text above is alarming. Any ideas?

Surely that is self explanatory:-

"you should rename the target file to allow the automatic sym link to occur and remove this error, unless this is an intentional "

so just answer that question and if it wasn’t intentional you should act on it, no?

Renamed the file, rebooted, same error. Also have modules that won’t install now since the batch of updates for this version last week. And four modules are disabled:

“The following modules are disabled because they need to be upgraded:
sysadmin, webcallback, vmnotify, calllimit”

SysAdmin won’t upgrade because it says the RPM is too old. Followed the instructions to update via YUM and the problem persists. Is it possible that some module updates were released incorrectly for this version (1.817.210.58-1)?

You need to upgrade your distro well past 1.8 if you want to keep getting updates from FreePBX module admin, Module admin has no idea what distro or version you are on. Sorry.

Huh? Module Admin has shown no updates for this system in many months, until suddenly there were about 14 late last week around the same time as the 0-day came up.

What you’ve said isn’t reflective of what we’re seeing.

Actually my wording was a bit off but what I said still follows as true. In module admin, FreePBX will show you whatever module is in it’s xml. This is how it has ALWAYS been, you’ve always had the option to use version upgrader to go from 2.10 to 2.11 (I assume you are on 2.10). It’s just now we re-evalutated many modules from 2.11 and released them back on 2.10.

Sysadmin is different in that it requires the RPM, But it’s up to you to determine if you need to install sysadmin, sorry we pushed it to you but 1.8 is EOL.

As I said, FreePBX has no idea what distro or version of distro you are on, you could install FreePBX without any distro. It shows the same modules for everyone.

Maybe this needs to be better, but this is how it is right now.

What version of sysadmin worked for you before? Do you remember?

What I care about is that Module Admin doesn’t show updates that will break a system; that are incompatible. Just like Windows Update doesn’t offer to install Windows XP updates for Win7 PCs. In this case it seems that some modules showed up for this EOL system that aren’t applicable and now I’m having to pay to have things fixed.

As I asked you before “What version of sysadmin worked for you”

I am not asking to mock you. I am asking because I will provide a release and a fix.

Thanks. I wish I could tell you. As mentioned, we’d not seen any module updates for many, many months for this system (we support others that are current). I believe all the modules were in version 2.10.x. Last week around the time of the 0-day, a whole bunch of module updates showed up in System Status and Module Admin. They were, I think, all in the 2.11.x version. Now the four mentioned won’t load and we have the symlink issue I originally posted about.

I very much appreciate the offer of help. Thank you.

Please see if the sysadmin 2.10 works for you. Its in the online repo now so you can force a download when you check online for updates.

No dice.

From Module Admin:
Please wait while module actions are performed
2.6.1 18_centos5 ERROR: Unable to install sysadmin. The sysadmin RPM you have installed is too old. Please update the sysadmin rpm via the command line, using yum install sysadmin
Error(s) installing sysadmin:
Failed to run installation scripts

Using YUM:
[[email protected] ~]# yum install sysadmin Loaded plugins: fastestmirror, kmod
Loading mirror speeds from cached hostfile
Setting up Install Process
Package sysadmin-2.6.1-18_centos5.noarch already installed and latest version
Nothing to do

You are attempting to install the sysadmin module 2.11 again, please download the 2.10 sysadmin like I asked.

When I tried to install it via Module Admin it shows as 2.10.0.77

Publisher: Schmoozecom.com
License: Commercial
Description for version 2.10.0.77

Sorry to be uninformed, but aside from YUM, Module Admin, and a direct download, I don’t know how to install modules. Can you please provide some brief addition directions?

The message you are providing “The sysadmin RPM you have installed is too old” is not in the 2.10 code base it is only in the 2.11 code base this is why I know there is a problem with something you are telling me or something with your system. Uninstall the local sysadmin module and then download it again from module admin.

I’ve opened a support case and Robert K. has looked at the system, FYI. The options in Module Admin for SysAdmin are “No Action” and “Install”. It shows as “Available Locally”.

The Description field now shows 2.11.0.40, though I am entirely certain that it was 2.10.x yesterday and that this change between what it’s showing happened earlier this week as well. Aagain, all I did was install the module updates that appeared in Module Admin the week of the 0-day. The SymLink error is still there, though both I and Robert have renamed the file per the error message.

If you can tell me how to remove the module I will gladly do so, but I don’t have that option from Module Admin.

Also: After it showed 2.11 above, I clicked the “Check Online” button and it’s now back to showing the 2.10 version.

I have 2.11 installed and I get the same symlink message. I removed the file (/etc/asterisk/logger.conf) and a applied changes, but it still get the same message.

Hi-
We need to get this resolved. I had a support case opened, but they closed it when I sent them a link to this thread:

“I am glad that Andrew is engaged with you in the Forum. Please understand that I am limited in the support system as to how I engage with you. At any rate, Andrew is the go to guy for this type of issue.”

The SymLink error persists and the SysAdmin module is disabled. Now there are five other modules that were updates to 2.11.x versions that want to update. I’m holding off on that until I have further direction.

I have reopened your support ticket and assigned it to myself.

rm -rf /var/www/html/admin/modules/logfiles