For anyone using Superfecta, does pushbullet module work for you?

I’ve configured superfecta. Configured pushbullet as the last item in the list. Set my api key.

Now when I run a debug/test and manually enter a number. it checks the phonebook/etc and then send the name to PushBullet.

When I have an incoming call, superfecta finds the name by checking the phone/etc, but never sends it to pushbullet. Would love to know if it’s just me or if others are experiencing this.


Maybe your problem is related to this?

Good luck and have a nice day!


Hey Marbled. Unfortunately I tried a doing a new install, and same issue. Also tried using both the existing and new PushBullet module. Thats why I’m hoping someone else is using PushBullet can comment if it’s working. (Or someone with Superfecta could try pushbullet:)

I am using the edits that I noted the other day, and it works for me. Move it to the top of your list and see what happens.

Hi Lorne,

You are correct. If PushBullet is at the bottom of the list, then it will not send the data to PB. If however it is at the top of the list it does. Personally I put it at the bottom of my cid checks so that after gather all the info it would then send to PB. I assumed if it was at the top of the list it would not check the sources for name info before sending.

My list currently has PB 1st, followed by AsteriskPhone book. And when an incoming call comes in, it matched it from the phonebook and sent that info to PB even though it was after in the list. I haven’t test with results from 3rd or 4th in the list, but hope it works.

Thanks for all your help! :smile:

This is a bug, feel free to file a ticket at

Hey Lorna, just to give you a heads up, somehow the module seems to have stopped working Nov 23rd. And if i put in either the original pushbullet module file or yours, FPBX complains about the exception again. Also with your file, I’m also warned that the file has been modified. not sure if Something has change in FPBX or wish pushbullet recently, but the module is broken again. :frowning: