Stun Server in FreePBX

i’ve a big problem. I use a ISP Connection that filter 5060 port. I try with many things, Ata adapter, xlite, softphone and every thing work only if i use stun server.
I use CloudItalia (ex Eutelia)


If i not use Stun on my xlite, ata adapter… i can’t use my geografic number for incoming call. Cloud italia say that the number i call is unavailable… if i use stun i correctly receive calls.

NOW. I want use Freepbx, and i follow thousand of guides for try to use a stun server in a trunk.
I’ve try to:

  1. use in my trunk
  2. put stun server in Advanced SIP settings (section STUN after RTP ports)
  3. put stun in Advanced Sip Settings->Chan Sip Settings->Other SIP Settings in this mode:
    stunaddr =

but nothing of that work.

How can i use this trunk in my connection with freepbx for incoming calls?

p.s. i use another trunk with freevoipdeal account that work correctly for outgoing calls (with audio ok)

someone can help me?

Hmm interesting, have you tried in the rtp.conf file?

How? I must edit this file using putty? (SSH connection)

what i must insert in this file?

I realized today that the “General SIP Settings” under the Settings tab has all of the STUN setting on the main page. That makes sense, since they are common to both SIP Channel Drivers.