Stuck at "Sangoma Smart Firewall is now enabled!"

firewall
Tags: #<Tag:0x00007f4f434cb5f0>

#1

In order to try to resolve a different issue, I decided to go through the “Re-Run Wizard” workflow on the Firewall page, and ended up at a page with a heading “Sangoma Firewall is now enabled!”, and the options to “Abort” or “Continue.” Unfortunately, clicking either of these buttons seemingly does nothing. Also, even though the menus are available at the top of the screen, everything I have tried to click brings me back to the same page. It seems I am stuck…

I have not attempted rebooting, as this is a live server, but may try that during off hours tonight. Has anyone seen this issue, and if so, know how to resolve it?

My initial


#2

I am also experiencing this issue.

What happened was I couldn’t press any buttons within the firewall configuration so as tim007 did, I ran the reconfiguration wizard perhaps expecting it to fix the issue. Instead, it locked the GUI into the firewall setup screen and pressing either of these buttons will do nothing. So I am now completely locked out of the GUI. I have tried disabling the firewall through SSH.


#3

As a quick fix to get back to the GUI I found you can disable the firewall module on the console using fwconsole moduleadmin disable firewall
Module firewall successfully disabled
Updating Hooks…Done


#4

I was able to fix the issue by doing this:

  1. Disable the firewall module using “fwconsole moduleadmin disable firewall” from ssh.

  2. Update the FreePBX Framework.

  3. Re-enable firewall module in module admin.

  4. Everything works now.


#5

Thanks. Your first tip about disabling the firewall from the console got me started down the right road. Given the version notes on the FreePBX Framework update, I suspect that the “overly restrictive htaccess” settings may have been at fault. All seems well now, at least with this issue.


(Fuad Mehdiyev) #6

Thanks, it helped me to solve the same issue.