Strange problem with chopped audio

Hi to all.
I installed, two years ago, a FreePbx and it functioned happily until six months ago.
From then until now, on incoming calls, I listen perfectly the remote parties ,but them listen my audio “chopped” , same problem exists for outgoing calls.
At first I thought that it was a NAT problem, but there was no configurations changed from the installation, and no changes was done by the carriers.
So I updated my installation with a new server with the last FreePBX distro ( 13 ) and a new Internet carrier , but problem remains . At moment my installation is composed by a server with two NIC ( one linked to ADSL router , the other linked to a LAN made only by phones ) , the ADSL natted my PBX
in a 192.168.2.x network, and my phones are linked to a 192.168.1.x network . I declared the NAT between the FreePBX and external IP .
RTP ports ( 10000-20000) was opened on the router and points at server IP address . Sip driver in use is Pjsip . Calls between internal exstension function very well .

Has, the community, any hints to solve this strange problem ?

sounds like you’re dropping outbound packets which suggests your ADSL upload bandwidth is crap.

As @ashcortech says, your upload bandwidth is likely being saturated. What download and upload speeds should your service provide? What does a speed test show?

The competing upload traffic could be running in the background, e.g. cloud backup or security cameras. Or, it could be unwanted, e.g. malware or a neighbor using your Wi-Fi.

Make a test call where you can repeatedly record some audio and hear it played back. works well, but if it’s expensive from your location, call your mobile and let it go to voicemail. After leaving a message, use the options to review and re-record.

Then, try turning off other sources of traffic and see whether the audio problems stop. First, disable Wi-Fi, then try unplugging the LAN ports on your router, other than the one from the PBX. If there is a switch between the PBX and router, try temporarily connecting the PBX directly or disconnecting other devices. If other traffic is causing trouble, a router with QoS can give priority to VoIP, which should fix your quality issues.

If outbound audio is still bad, even with all other devices disconnected, try configuring an IP phone to communicate with your trunking provider directly (instead of through the PBX). If that’s also bad, there is a problem with your ISP. If it’s ok, there may be processes running on the PBX that are competing with Asterisk for resources.

Thank you guys,
I had already conducted many of tests suggested by Stewart1, also with the help of the provider’s sfaff.
The upload/download band seems to be good and latency is good also.
At moment on the internal LAN, only phones are connected, no wifi, no other nosiy sources are on LAN , on Internet side just the PBX and ADSL are connected.
The only thing is that ADSL connection is routed from a Microtik router which use two Internet connections one via radio link ( the main connection ) and other via landline ADSL ( the emergency connection ) .
I have no control on this router , so I must trust on provider declaration about the goodness of these links . The ADSL access is barred in many ways only the pbx can use it the ADSL,the firewall, as provider said, routes ports 5060, 10000-20000, directly to pbx .

I tested also phones directly connected to trunk, the results was better, but the problem was still there

For sometime I begun to consider the hypotesis of a misconfiguration in the Microtik…
But I wanted to make sure that this problem didn’t depends from my guilt.
Your words seems to confirm my suspects.
Now I try to lease an external server and test same pbx configuration …

Thank you to all

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.