Strange Jitter on server


I have some strange problem on one of my Phone systems.
Sometimes during a call we get Jitter on a server (TCPdump on server). we see a delay in the RTP packets inbetween of 0.1 and 1.1 seconds. What causes a silence moment in a call. There is no packet loss just this strange jitter. The jitter is visible on all the legs so in comming and outgooing. it does not matter if it is a internal call or an external call. All phones are connected directly one the network no NAT or anything only the VoIP trunk is gooing through NAT. the phone system is installed on Proxmox 4.3 (KVM virt) we have multiple phone sytems running on the same server and they dont have this problem. If we start a ping to we dont see the delay jusst a stable ping of about 7ms.
The server has 2 NIC’s and about 5 static routes (to reach the diffrent sites) disk and NIC are Virtio based.

I hope someone has an idea?


Nobody an idea?

It sounds like a virtualization issue with higher packet rates to me. Have you tried using mtr instead of the normal ping tool? It combines ping with a trace route, and if you set the interval low enough, you can get a decent number of packets flowing. If you see the jitter go up as the interval goes down (and the packet rate goes up), then you’ll know there is decent odds that there is performance issue with the VM or the network it is attached to. From there perhaps see what us different about that VM from the other normally running ones. Does it have the same virtual nic? How is it attached to the physical network (ie bridge, vswitch?, something else?)? The same or different from the others? What is different about that VM’s layer 2 network from the others? Maybe you have a bad switchport somewhere…

Hi Yokem,

Thanks for the reply!!

I tried MTR with -i 0.01 saw the packets rise very very fast. But no Jitter. it seems something from within Asterisk.
I uninstalled many packages that i thought are not nessecary, Like the iSymphony server. could that be a problem?