Strange IVR '1' issue - cannot hear ringing sound

I’ve a strange issue occurring with an IVR setup - if one selects option 1 of the IVR, which calls an extension directly, the caller does not hear ringing, although the phone is ringing.

All they hear is dead air for about 15 seconds and then the voicemail when it picks up.

If you select option 2, 3, 4… also set to call extensions directly, then the caller hears the ringing. The problem is only with option ‘1’ and it does not make a difference which extension is being called by that option.

If you dial the extension directly from the IVR, you hear the ringing.

The inbound trunk is an IAX trunk - if using a zap channel, one hears the ringing.

This leads me to think it is an IAX problem somewhere but it just appears mighty strange and why would it work for other IVR options and not option ‘1’?

Background details:
Asterisk 1.4.22
FreePBX 2.5.1.0
IVR Module 2.5.20.5

NAT is not involved, all local network phones.

Asterisk dial command options: tr
outbound dial comand options: T
Extension ring time is default (15 seconds)

IVR is setup as follows
1 --> Ext 211
2 --> Ext 212
3 --> Ext 214
Direct dial is enabled

I also compared the console output between dialing directly and pressing 1 on the IVR and they look the same. They both indicate

– Executing [[email protected]:7] Dial(“IAX2/2125551234-13114”, “SIP/211|15|tr”) in new stack
– Called 211
– SIP/211-08c27c70 is ringing

Anybody come across this before or have an idea in trying to solve the problem?

Thx

Hey weirdd … i have the same issue … did you find the problem …

Send me an e-mail if you have any idea what to do
[email protected]

David

Nope, haven’t figured it out yet - The IAX provider (unlimitel) claims it is an IAX bug, but I don’t believe it (or at least I can’t find the bug report) on Digium’s site.

I need to test with another provider, but haven’t had a chance to set that up yet or do some traffic capturing to see the differences.

Anyone else with some thoughts?

If i dial an extension directly from inside, i get a ringback tone. If i dial an extension from the IVR, the extension rings, but no ringback tone. No idea what’s causing that yet.

My issues was specific to using an IVR and option ‘1’ of the IVR. If I called in and dialed the extension directly, I received ringback, dialing “1” I did not.

I did narrow it down to IAX as I tried with a SIP account and it worked. For now, they are adjusting their IVR tree and excluding ‘1’

My setup is the following: I have an IAX Trunk with DID coming into an IVR with Direct Dial activated. When I select either of the incoming options through the numbers 1 through 6 or dial an extension directly I get no ringback.

The only time I get a ringback is the very first time after a restart of Asterisk that I get ringback but all other calls after that do not get ringback but when answered eventually by the voicmail or the user the conversation is normal.

This must have something to do with IAX because I have set up an DAHDI-MFCR2 did into the same IVR and I get ringback every time! The problem is I can only use the IAX trunk for this funtion so I need this to work. Any ideas?

I am still having the same issue even after upgrading to 1.6.2.0RC3. Anyone else had luck in solving this issue??

FreePBX ver 2.6.02 Running on ESX server with Linksys SPA400’s
Problem is I don’t hear the ring back (although the SIP phone is ringing. Internal I hear the ring back. I have been able to reduce the “dead” time by adjusting my ringtime default to 8 (this causes other problems) It seems to be tied to the IVR and direct dialing of an extension.