Strange AAstra 6757i phone antics

I have a small office (ours) with Freepbx 2.10 / Asterisk I have 3 6757i phones that have been flaking out. Randomly the speed/xfr to 70 will not work. Most of the time the Xfr to an extension will not work. I have tried to configure the phones using PBX endpoint manager. But that didn’t work any better than now. I defaulted the phones and programmed them individually (easy since only 3). but they still do odd things.

The phones haven’t been rebooted, my DHCP server isn’t serving up the Freepbx as the TFTP server location.

Can anyone help me out here? I know enough that I have seen that creating the XML files for these phones is the way to go. But, I do not know how to do that. I need a AAstra XML for dummies if there is one.




I’ve had some odd problems with 6757i phones myself. Mine were putting people on hold and then the phone would not allow the call to be retrieved. Eventually I downgraded the firmware and the problem went away immediately.

The phones really work well with a DHCP/TFTP setup. While the size of your rollout is small all of the skills you learn there ramp up to larger installs. With that, what system is serving up DHCP? Is it a Windows server, Linux server, or router? Most routers are not fancy enough to allow you to add a TFTP pointer. If you are using a Windows server make sure your TFTP folder is shared everyone/everyone. I use SolarWinds TFTP since it is a decent one and a freebie. Some people like Linux for their DHCP but since most of my environments are Windows it is better for me to use Windows’ DHCP so it ties in with Windows DNS and AD.

For your XML file sitting in the TFTP/shared folder make sure it is named correctly. For example


Also place whatever firmware you want your phones to use in that same folder. It should be named I’ve included an example of my 6757i XML cfg file below. Edit yours accordingly. After you have everything setup then:

  1. log into your phone’s IP address with a web browser, default username and password is admin/22222
    2)choose Operation> Reset> Restore to Factory Defaults <<NOTE: this will nuke all of the current settings on your phone>>
  2. choose Operation> Reset> Reset Phone
  3. your phone will reboot, find the TFTP/shared folder, load the firmware if different from existing, and then load the XML cfg.

–start of cfg file-------------------------
sip auth name: 510
sip password: XXXXXXXX
sip user name: 510
sip screen name: Tech
sip screen name 2: 510
topsoftkey1 type: speeddial
topsoftkey1 label: VM
topsoftkey1 value: *97
topsoftkey1 line: 1
topsoftkey2 type: speeddial
topsoftkey2 label: Page
topsoftkey2 value: 22
topsoftkey2 line: 1
topsoftkey3 type: speeddial
topsoftkey3 label: Park
topsoftkey3 value: 70
topsoftkey3 line: 1
topsoftkey4 type:
contrast level: 2
bl on time: 180

–end of cfg file-------------------------

Thanks for the info. The firmware version I am using is bootload is You mentioned downgrading the firmware. What version works? I found a whole bunch of versions on the AAstra site.


+1 on firmware as the culprit. I have standardized on, the last of the 2.x branch. Periodically I try the newest 3.x and run into a quirk that was not present in ver. 2 so I resist all temptation to upgrade. Early versions of 3.x were the pits.

Meant to say also my DHCP is over my router and it can point to a TFTP server. Should I not use the phone server for this? I have that TFTP server on my laptop anyway.

I have TFTP32 running on my pc with the file and the cfg file for my phone in it. I defaulted the phone. I originally put into my DDwrt router the DHCP option 66. I also manually put in the TFTP server IP into the phone from the phone Admin. The phone never accesses the TFTP server. The phone did default. What is the “Redirector” that comes up on the screen.

I also use the 2.6.x firmware on my 6757i phones.

Putting the TFTP server on your VoIP server is not bad it is just something that never worked for me in a big picture plan.

If DHCP is working properly you should not need to manually add that to the phone’s cfg.

Where is your aastra.cfg file is it also on your TFTP server?

Here is a copy of mine.

  • the tftp server line needs to point to your tftp server
  • for now, just put your cfg files in the tftp’s root folder, otherwise edit the path statement
  • the sip server should point to your PBX IP address
  • adjust the time zone accordingly
  • use time servers close to you

–start of aastra.cfg----------------

tftp server:
tftp path: /

sip registrar ip:
sip proxy ip:
sip proxy ip:
sip outbound proxy:

sip registration period: 60

missed calls indicator disabled: 1

time zone name: US-Pacific







time server1:
time server2:
time server3:

#live dialpad: 1
#options simple menu: 1
#date format: 2

#hostname: Aastra-SIP
#admin password: 22222
#user password:
#web interface enabled: 0
#sip send mac: 0

–end of aastra.cfg----------------

Also, not meant as a thread hijack. Just want to bundle all of the Aastra 6757i notes together…

At one brand new site, new cat6 wiring, new 1GB switches, etc. All of the Aastra 6757i, 6730i, and 6730 phones had horrible distortion when the in-house caller spoke. Ran through a bunch of fixes with no success. Eventually pulled them all out and replaced them with Cisco SPA942 phones distortion went away immediately. Moved the Aastra phones to my company and still use them to this day with no distortion issues. They just didn’t work in the other office for no reason I could ever find.