Stopped working even when reinstalling. How to don't allow updates?

I had a FreePBX v4.211.64-9 working for 10 years now, and the GUI self disabled itself (see attached image).

(Even if old it’s not a security problem since it’s not accessible outside of the LAN except for the SIP trunk)

I cannot update it to ANY other version in any way: it always fails.
Also installing ANY newer version, it immediately breaks when restoring the old backup.
I have tried several (more than 30) times, any version / update combination!

So being desperate, I tried to reinstall the v4.211.64-9, but every time I do, as soon as it gets connected to the internet, it immediately SELF-BREAKS again.
I tried to block every and subdomain, but it somehow always gets online and instantly breaks itself again and stop working.

What domain should I block and how? Because it works perfectly as long as it doesn’t try to update!
Please help, I am completely unable to fix this box and spending several weeks on this I don’t know what else to do I can’t even update, migrate, or register properly.

dont connect it to the internet if thats causing the system to breaking your case …

take a backup and get that backup off the system

if the UI is functional when its not connected to the internet sketch out the system details possibly keeping it up for reference and build out a new one side by side with that info

thats my suggestion considering the circumstances you’ve described

Thank you for your answer, I already have the working backup, it works perfectly as long as the computer is in LAN only and disconnected from the internet.
…But then how I am supposed to use the SIP trunk offline?

Is there any way to stop the self update “v4 to v12” that appears on the menu? I already tried to follow the update and it self breaks again, and if installing directly the v12 or v16 it breaks as soon as I restore the backup from v4.

I just want it to works, i have no idea what to to, every single options is a dead end

cdolese is saying to not upgrade but setup a new freepbx system from scratch and instead of restoring from backup setup everything by hand since you can have a working system still running to look up your current configuration without connecting it to the internet.

Unfortunately I can’t do that because it’s hundreds of extensions.
I would have gladly paid a license if any of the possible options even worked
I even tried to install asterisk and copy the configuration from the /etc/asterisk folder but it didn’t work, now I am using an ethernet tap to find with wireshark where this freepbx is connecting to self-destroying itself but I am not sure I will find a solution… if anyone has any idea please help

No idea if this is even an option but have you thought upgrading step wise through the versions until you are at the latest?

Install a fresh v5 system and restore your v4 backup to it, then install v6 and restore from your v5 until you are at the latest functioning version?

It looks like you can still download legacy versions of FreePBX from the download site:

I don’t understand how is it always stop working as soon as it gets access to the internet, even if iptables is not allowing ANY tcp traffic, input nor output on any port.
Do you have any information on why is this happening and how to make it stop?

Using Bulk Handler, you can export the extensions from the old system and import them to the new.

There is no bulk menu in v4, this is why the first thing I tried was update to v12. But it breaks.
Also installing v12 and importing the old backup breaks.

(Out of desperation I was starting to think to install it into a VM with a strict firewall, and/or try Elastix)

Have you tried a fresh install of v16 and restoring the backup?

v12 didn’t support restoring from other versions.

Failing that, your only sensible option is to start from scratch. Obviously the bulk handler in v16 will allow you to create a spreadsheet and upload which will at least be quicker than manually creating hundreds of extensions.

1 Like

THANK YOU IT WORKED! It somehow managed to import the legacy backup. Thank you so much for your support!!!
Marking as solved, I am now buying all the commercial packages that are currently not working

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.