Stop yealink RPS Auto provisioning


#1

I have a customer that switched from a hosted provider to my freepbx the old hosted provider setup yealink RPS so it doesn’t matter how many times I factory reset the phone will reach out upon connection to the internet to yealink and get provisioning information from my old provider is there any way to stop this without contacting the old provider they are not very happy that we switch to freepbx


#2

You may have to appeal to Yealink to override the previous owner’s RPS settings with your server. See
http://support.yealink.com/documentFront/forwardToDocumentDetailPage?documentId=257
page 9 of the admin guide.

If you have reasonable evidence that you are the rightful new owner of these phones, I’d expect them to cooperate.

If you get no satisfaction there, reset the phones and set them up (via their web interface and with no connection to the internet) to provision from your server. If you are careful, you should never have to reset them again. If you do lose control of one, you’ll have to repeat the process for that device.


#3

the problem is even if I turn off provisioning settings the second it connects to the internet it Provisions regardless of the settings I have never dealt with their support with this issue I hope they’ll help me because I’m not the reseller


#4

they finally responded to my ticket they gave me two options send them a picture with the MAC address or a receipt of the phone I sent them a picture and they removed it from RPS


#5

I started writing this before you posted the solution; the comments below may help other readers.

If you have a relationship with a reseller to purchase Yealink phones (for other customers who are not migrating from hosted service), ask them for login credentials for RPS.

If provisioning is on and pointed to your server and it still gets overwritten, perhaps you can set a static DNS entry in the customer’s router/firewall for rps.yealink.com that points to oblivion, or set static DNS in the phones that point to your DNS servers, which have suitable entries for rps.yealink.com. Unfortunately, the latter introduces a new point of failure.


#6

and most small businesses have ISP router without those features I’m glad support help me because I didn’t want to buy a new phone


(Jared Busch) #7

Then they are not a business, but a hobby. I refuse to work with a business that will not come up to minimum standards of not using ISP supplied hardware.

On topic: Yealink’s RPS will not override DHCP settings. If you set a DHCP option 66 pointing to your URL, and there is a file there, the RPS will not pick up on first boot of a defaulted phone.

With Ubiquiti routers, it is as simple as this.

set service dhcp-server shared-network-name LAN subnet 10.254.103.0/24 tftp-server-name 'http://pbx.domain.com:84'

or

set service dhcp-server shared-network-name LAN subnet 10.254.103.0/24 tftp-server-name 'https://pbx.domain.com:1443'

On Windows DHCP Server it is here
image


#8

what I do is explain to the customer exactly why I want a pfSense Appliance and qos basics, if they still choose to stay with ISP routers and if they will have audio issues, they’ll have to take my router and they won’t be able to blame me, what I won’t touch with a 20-foot pole is double NAT

nice to know about option 66 stopping Yealink RPS, but that would not be my first choice because if someone swapped out routers without me knowing, or some other scenarios I’ll have to reprovision all the phones, and I don’t buy endpoint manager everywhere, as long as I have the same experience every time I want to remove phones from RPS with Yealink support I’ll be very happy
they should have a setting to override RPS, it feels like they used to do with smartphones with locking to a carrier


(Jared Busch) #9

That is what this is. Once a phone is provisioned, it will never reach out to RPS.

Unless the “new” device points to a new location with a valid configuration file for the phone, the phone will simply continue to use the provisioning server address it already has from the last time it talked to the valid server. Your only issue in that scenario would be if a phone was defaulted, it would again see he RPS.

EPM has nothing to do with it. The provisioning services are setup on all FreePBX systems by default. You just need to make sure the firewall settings are correct for your needs.


#10

what I tried is factory reset manually setting up the phone it worked for a while until one day the phone decided to pull configurations from RPS and deleted all my configuration and change the password, I’ll test option 66 if I bump into RPS again, thanks for the advice, I hope this info help someone in this situation


(Jared Busch) #11

Correct, if you never setup any type of auto-provisoining, then it will never disable the RPS check.


#12

I tried putting a random website in the provisioning menu on the phone web GUI I guess it has to be a valid address to a freepbx


(system) closed #13

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.