Stop ringing with Polycom 335 and headset

We recently replaced a proprietary phone system with FreePBXWe are using FreePBX 13.0.143 with Polycom 335 phones and iSymphony Most of the staff just use handsets (no headset). If they initiate a call or attended transfer via iSymphony their handset rings, which makes sense since they need to pick it up to talk to the called party.

The call center staff all use headsets. If they perform these same actions their handset also rings. Under the old system the phones would recognize that the headset is present and auto-pickup these kinds of calls.

This matters to the call center staff because they’re all trained to grab ringing phones, even phones of other call center staff, so they’re getting a lot of false alarms from these extra rings. Clearly the phones are capable of auto-answering these kinds of application-initiated calls, since the old system could do it with the same phones. It may just be a programming option on the Polycom, but I’ve tried all the obvious options without success. It also may be something FreePBX or iSymphony needs to send to the phone.

Can anyone shed any light on this? Is this a FreePBX issue, a Polycom issue, or an iSymphony issue? Has anyone resolved this?

Moderator: Please feel free to transfer this item if there’s a more specific forum category for it. Thank you for your assistance.

Which was the proprietary system that you replaced?

Have you tried the information here: Polycom Autoanswer Search

This was the first link Google sent me to, and you (of course) searched all through Google to find the answer to this question, right? Just kidding.

Let us know what (in that link) isn’t working and we’ll probably be able to narrow your issue down further.

ICCC, aka IC3 from Interactive Intelligence. I didn’t maintain it, so I don’t know much more than that. It ran on three Windows machines (main system, media center, database server) and used SQL Server for back-end data.

Looks like they are just Avaya resellers - their PBX is all Avaya. The “custom” management frontend looks kind of interesting.

Our system was about 4 years old, so the product line-up may have changed since then.

what kind of headset? assuming you have the headset properly plugged in, then go to menu -> settings->basic->preferences->headset and set the proper options. you for sure want headset memory turned on so that the phone remembers how you last used the phone, set the proper switchhook mode for the headset you are using and turn on echo cancelation

Login to asterisk cli, make a call through the isympony to one of theses phones with the headset, post here the log.

bksales recommendation to set the headset memory resolved the issue. The call center is very appreciative, as am I.