Stop recording after blind transfer

Can anyone tell me how to stop a recording after I make a blind transfer?

I have an extensions to capture credit card information, but when I blind transfer the call to this extension, the call continues to get recorded. I need to stop the record and then when the call returne to the agent, it should start recording again.
It is not a problema if it generates two files.

Any thoughs would be appreciated.


I think you’ll need to create a special context in the “Freepbx-override” file to handle your transfer.

Any ideas on how to do this?

I really don’t know where to start.

Thank you!

Without writing it and testing it, I can’t say for sure, but the following should get you (or someone) started:

  1. Copy the existing “blind transfer” context to the “Extensions-FreePBX-Override” file (I don’t have the exact name).

  2. Modify that context to issue a “stop recording” command in the context.

  3. Figure out which context you are coming back to after the transfer so you can restart recording.

Like I said, I don’t have the code right here in front of me, so I can’t be more help than “Try something like this”. The override extensions file is important because you want to change the functionality of the blind transfer to stop recording.

Another possibility would be to add a new context and associate it with a command sequence that does this - that way, you don’t have override the existing context, you can extend it.

Another option would be set the “credit card” extension to NEVER record. That should override the recording and stop it on the transfer. Of course, that might not work if you have “record all incoming calls” set as the default for your recordings.

I’m mostly just thinking out loud. One of those should get you started down the right path (eventually :slight_smile: )


Thank you very much Dave.
I’ll see what I can do from here.