SSL Cert and Sangoma Phones

Who else uses commercial SSL certitficates with Sangoma phones and works with https provisioning and tls? I have been going at this forever I cannot seem to get the Sangoma phones to provision via https or use TLS with a COMODO certificate. It will work with a LetsEncrypt but that is not an option. I have gotten the Polycoms and Yealinks to provision with HTTPS and register with TLS and use SRTP perfectly on a COMODO cert but i cannot get the Sangoma to work.

There are no errors in the apache log.

You’ll need to include the root chain in your certificate bundle so that the phone can properly determine who is the correct certificate authority.

It works in freepbx with let’s encrypt because we supply the certificate chain that helps link the phone to the highest authority

I just checked the certificate and the root chain is also installed… and the phone still will not provision.

We just recently had to replace our signed certificates and we purchased a Comodo certificate. All functions of our PBXact system were working on a RapidSSL/GeoTrust certificate with Sangoma s500 phones. HTTPS provisioning, HTTPS phone apps etc all worked fine. Upon replacing the certificate we did not immediately notice a problem. The web GUI reloaded and it appeared fine, then we noticed that all PhoneApp function stopped working.
We did not link it to the SSL cert, however after extensive testing, we found the Sangoma phone will not provision, or update using the Comodo SSL certificate. We had to enable HTTP provisioning and HTTP PhoneApps and then re-provision all the phones manually via the phone web interface.

So the web GUI works, I can access the https provisioning url on a desktop browser without issue and the correct certificate is returned but the Sangoma phones do not work at all with the Comodo cert.

We have included and verified that the certificate bundle for the root chain was included and installed. The SSL cert was installed completely via the PBXact web interface.

Would love to get this working correctly, if anyone has run into this and solved it please post.

I gave up on the sangoma phones with the comodo certificate. When Sangoma fixes that issue I will be getting yealink and polycom phones for the time been.

Has anyone opened a feature request or bug report on this?

I have. About 2 months ago.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.