SSH backups

Hi All,

Recently I switched my FreePBX from a POC server to an actual production server and let me say, I love it! Since this server is now a production server, I want to do weekly backups just in case of a disaster.

I followed the guide for “Warm spare backup”, but it’s just a CentOS 8 server. I’m using SSH for the backup, got the ssh keys working. When I run a backup, the backup mentions it’s successful but I don’t see the file on the centos box at all. Not sure what’s going on!

Here is the section for the logs that gets emailed to me:
Finished Cleaning up
Finished created backup file: backupfile.tar.gz
Saving to selected Filestore locations
Saving to: SSH:‘BackupServer’ instance ,File location: /mnt/ExternalBackups/FreePBX/backupfile.tar.gz
Finished Saving to selected Filestore locations
Generated Backup process result email to [email protected]. Status: Success

Figured it out. It was a ID10T error. The issue was permissions! It would’ve been nice if the logs mentioned it had permission issues, once I fixed the permissions on the mount, it worked with no issues.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.