FreePBX | Register | Issues | Wiki | Portal | Support

SRPM availability


(Mat Phillips) #1

The list of files available here: http://yum.freepbxdistro.org/pbx/SRPMS/asterisk/13/

seems to stop at Asterisk 13.18.3, but the currently running Asterisk version on a fresh FreePBX 14 installation (when choosing Asterisk 13 and updating through the web UI of course) is 13.18.5

I doubt it will break things is I just the the .3 srpm, but could a current one be provided?
Also, is there an expectation of moving to Asterisk 13.19?

Many thanks


(Andrew Nagy) #2

Distro 7 has had 13.19 for a couple of weeks and all srpms are there as well


(Mat Phillips) #3

Is Distro 7 something different to what can be downloaded from https://www.freepbx.org/downloads/ ?
Version: STABLE SNG7-PBX-64bit-1712-2 available there is 13.18.3 when choosing the recommended Asterisk 13 install.

Do you have a link to the srpms?
thanks.


(Andrew Nagy) #4

You can upgrade Asterisk through the CLI after install. We don’t update the installer for every Asterisk release, that would get out of control

yum install sangoma-devel
yumdownloader --source <rpm>

As you’ll note here on every RPM it’s marked with shmz6.5. Which is the old distro. Not the 7 distro. If you use any of these SRPMs on the new distro you will break the system.


Srpm sources
(Mat Phillips) #5

I did not notice that 6.5 part! Oops, that may explain some things!
Will probably start a fresh install and step through things again, thanks for the tip.


(Mat Phillips) #6

@tm1000 sorry about this but could you clarify the update it from the command line after install part? I feel I should know this but cant find anything in the wiki’s about it, and fwconsole does not seem to be it.

thanks


(Andrew Nagy) #7

asterisk-version-switch


(Mat Phillips) #8

Thanks! Got it now running 13.19.1

When trying to get the source files though:

[root@pbx ~]# yumdownloader --source freepbx
Loaded plugins: fastestmirror, versionlock
Loading mirror speeds from cached hostfile
No source RPM found for freepbx-14.1-1.sng7.noarch
No source RPM found for freepbx-14.0.1alpha34-1.sng7.noarch
No source RPM found for freepbx-14.0.1alpha33-1.sng7.noarch
Nothing to download

[root@pbx ~]# yumdownloader --source asterisk
Loaded plugins: fastestmirror, versionlock
Loading mirror speeds from cached hostfile
No source RPM found for asterisk15-15.1.3-1.sng7.x86_64
No source RPM found for asterisk15-15.2.1-1.sng7.x86_64
No source RPM found for asterisk14-14.7.5-1.sng7.x86_64
No source RPM found for asterisk14-14.7.3-1.sng7.x86_64
No source RPM found for asterisk15-15.1.4-1.sng7.x86_64
No source RPM found for asterisk13-13.18.3-1.sng7.x86_64
No source RPM found for asterisk13-13.18.5-1.sng7.x86_64
No source RPM found for asterisk13-13.18.4-1.sng7.x86_64
No source RPM found for asterisk15-15.1.5-1.sng7.x86_64
No source RPM found for asterisk13-13.19.1-1.sng7.x86_64
No source RPM found for asterisk13-13.19.0-2.sng7.x86_64
No source RPM found for asterisk14-14.7.4-1.sng7.x86_64
Nothing to download

Searching for help with this with “freepbx get source yumdownloader” does not yield anything helpful.
I just need the source so I can apply a patch the the asterisk installation…

Any further advice?
thanks.


(Andrew Nagy) #9

I modified my original answer a few days ago.

yum install sangoma-devel
yumdownloader --source <rpm>

Also why do you need to patch the freepbx rpm? There is nothing you should be patching there.

yumdownloader --source asterisk15

You can also see a full walkthrough here:


(Mat Phillips) #10

I could be walking the wrong path. Trying to patch asterisk to support Cisco phones. Have it working great with Asterisk 11 right now, but there’s improvements in the functionality of the patch that are only available in Asterisk 13.

I didn’t notice the edit to the reply, works good now with the sangoma-devel installed. Downloading files now


(Andrew Nagy) #11

The freepbx rpm is basically a tarball container of freepbx at the time you installed the distro. So patching the freepbx rpm doesnt really net you anything, it even prevents itself from being reinstalled if it notices /usr/src/freepbx exists.


(Mat Phillips) #12

I was confused here for a bit, but worked it out. You’re questioning the two attempts quoted in the previous post. I’m not trying to patch freepbx. Your initial post just had “yumdownloaded --source” and I was just guessing at what should be written after it, and tried both ‘asterisk’ and ‘freepbx’ and then gave up and asked for further help.

No attempt being made to patch FreePBX, just a misunderstanding based on the original post.

cheers,
will be able to try the patching tomorrow and see how it goes, thanks for the help.


(Mat Phillips) #13

Yup, all good, many thanks Andrew.


(system) #14

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.