SQL failed, not failed?

Two days ago I was informed by our reception team that extension 400 was no longer working.
Since we could make calls out and I could diel my own extension I figured it was something dumb logged into the Admin GUI.
it was a mess of windows and nope. I should have gotten a screenshot but i didnt.
I found that the host computer was showing on the screen a long repeating chain of an error related to the firewall and SQL. i attempted to do a safe reboot with SSH commands, however the message and my inexperience hampered that and i just pressed the power button. Everything came up fine, however,
i had miss set the update settings and updates had not been done. i fired a whole set up updates.
and when i clicked on the dashboard this error would show up.
“SQLSTATE[HY000]: General error: 2006 MySQL server has gone away
if i click again right away it loads without issue.
google has not been helpful, as when i test it looks like SQL is working.

the updates have also failed. i am unable to update
each cause a crash related to SQL.
but somehow, time conditions still work. even disabled?

the host computer is an older HP Laptop, I5, 4gigs of ram, 500 some gig hard drive. system has been working since October.

Everything works now. but i cant update those modules and i still get that error when i open dashboard, sometimes.

any ideas? advice? am i completely screwed?
thank you for reading this far.

MySQL :: MySQL 8.0 Reference Manual :: B.3.2.7 MySQL server has gone away

Inspect the mariadb’s status. Turn it on and look what goes south. The MySQL service is failing.

That won’t tell you why it failed, just that it failed, the question was surely ‘why is it failing’ and then just wait for a substantive answer

Thank you all for your answers. I still do not have a conclusive understanding to what is happening. I am struggling a bit to understand the relationship SQL has with the PBX through Mariadb. The reference manual comtech left talks about communication issues, however, this is all local host same machine? and i would assume configured to discuss. i have not changed any files, i struggle enough with finding code to use in Lunix. Today the same issue happened, i ran “systemctl restart mariadb” at the hints from google and spioli, and the system came back online, so, we know this is where the issue lies. but why? i was smart enough to get a screeny this time.
any input or terms to search are welcome. thank you.

I attempted an update, and got the expected crash screen. Right after this I ran a check on maria, it is running. does this imply that sql is running?


fwconsole chown

Also is timeconditions installed?

was able to complete the chown command, however no change in behavior. Good idea. didnt know it was a thing.

the time conditions is not installed. it is disabled due to update and will not update due to this crash.
Oddly, the switching of IRVs continues on time.

Can you update the module from the CLI? Or did you already try that?

I have tried this many times. At this point i am looking at a fresh install. assuming i can remember how to do that.

After 4 attempts to install and crashes at 4 different locations in the process, i am chalking this up to hardware failure. Thank you all.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.