Speed dial international


(Ralph) #1

I have speed dial set up and working *0 and a number which works fine for UK calls. I added 2 international numbers UK dial code is 00 for international followed by country code and number. These do not work and appear blocked. I found a reference to enable pinless dialling which I enabled but still not working.
There appears to be a setting somewhere I need to change.
Any help please.


(Lorne Gaetz) #2

Going to need a call trace from a failed call:
https://wiki.freepbx.org/display/SUP/Providing+Great+Debug#ProvidingGreatDebug-AsteriskLogs-PartII


(Ralph) #3

Hi Igaetz,

Thanks for reply. Typed instruction into ssh tail -f etc as per link and putty just hangs no response
Ralph


(Ralph) #4

Hi Igaetz,
Update on last post, my fault had asterisk logs off. Now can see incoming data but not outgoing will check all logs are on but think this is the case.


(Ralph) #5

yes all log files are on no outgoing data, suggestions please.
Many thanks


(Itzik) #6

Are you saying that the log file is empty?

If not, please describe your issue that’s keeping you back fron posting a pastebin link.


(Dave Burgess) #7

@RalphGraham - you’re going to have to be more specific on this.

When you try to call out, what isn’t working? The things you need to look at are the Outbound Routes and the Trunks. Both have to be configured to allow the call to pass.

If you are truly seeing NOTHING in the logs (and I don’t mean the CLI, I mean the /var/log/asterisk/full log) then the problem is before the call ever gets to the PBX, which limits your options pretty severly. PIN-less dialing, et al, are not likely the problem - you need to make sure you’ve set up all of the outgoing filters and modifiers to make the calls happen.

Without showing us the logs, you’re not likely to get a lot more help.


(Ralph) #8

I have just tracked the problem to my Grandstream phones. Using my mobile to login as an extension usion Zoiper my international speed dial works perfectly. I conclude the Grandstream has some setting blocking international speed dial I need to resolve.
Thanks for your help guys and mark this one not Freepbx.


(Lorne Gaetz) #9

Ah now I see what’s going on. There is a dial plan (or digit map) in the phone that determines what is a valid dial string. It needs work.


(Ralph) #10

Problem now resolved but I have an odd thing still.
All speed dial numbers work including international but not if stored on speed 1 or 2
That is *01 and *02 any idea why this is so. I have moved those numbers to 11 and 12 so all work but just curious

Thanks


(Lorne Gaetz) #11

Need a call trace to know for sure what’s going on:
https://wiki.freepbx.org/display/SUP/Providing+Great+Debug#ProvidingGreatDebug-AsteriskLogs-PartII


(Ralph) #12

Thanks for your response.
Unfortunately I tried to do that earlier in this discussion. If I call *01 the call log shows nothing so I am not sure anything was sent from the phone to Freepbx.