SPA942 BLF with pjsip


(Nick Zed) #1

Just moved a system running freepbx 14 with all spa942’s to pjsip to allow some users to multi login.

problem is, other users, using chansip had working BLF, since migration to pjsip, the lines light flashes orange constantly.

if we hit the button it does call the extension, but does not show blf statuses when in use or when line is ringing, just flashes orange. that place only has the spa942’s no more modern phones, since its worked well for them for all these years, they will likely tell me to move them back to chansip rather than fork out thousands to replace 20 odd phones.

is there something else we need to do in freepbx when moving to pjsip to get these things to work again w/BLF ?

checked:
line key disabled
shared call exp private ( no work set to shared either)
ext functions use
fnc=blf+sd+cp;sub=ext@$PROXY;ext=ext@$PROXY
and yes its always been set to type “asterisk”
with call pickup *8


(Andrew) #2

Are you actually using $PROXY in your button config or is that just a placeholder to obfuscate your FQDN? My button config looks like:

<Extension_4_ ua="na">Disabled</Extension_4_> <!-- options: 1/2/3/4/5/Disabled -->
<Short_Name_4_ ua="na">Reception</Short_Name_4_>
<Share_Call_Appearance_4_ ua="na">shared</Share_Call_Appearance_4_> <!-- options: private/shared -->
<Extended_Function_4_ ua="na">fnc=blf+sd+cp;sub=100@pbx.domain.tld;nme=Reception</Extended_Function_4_>

(Nick Zed) #3

actually using it, spa942 know how to handle and translate this
interesting you get away without ext=
and you are using pjsip? what freepbx version, current release of 14?


(Nick Zed) #4

Weird and wacky!

Thanks Andrew, I removed ext=foo and the damn thing works :smiley:
No idea whats going on there, I guess it upsets pjsip somehow. then again its possibly Cicsco’s implimentation, the spa942’s era was late naughties when pjsip was rarely a thing.

Thanks for you rfnc line, all good now ( be interesting to see if the default method works on 7800 series which I recommend now days might try it :wink:


(Andrew) #5

Awesome, glad that was the solution.


(system) closed #6

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.