SPA400 problems

I’m having a problem with the linksys SPA400. I have it hooked up to a freePBX system and it registers just fine.

The first problem I’m having is when I place an outbound call the call gets connected but there is no voice on both sides. Example I will place the call from the freePBX to my cell phone. my cell phone will ring from the right CID number and I will answer it. the person on the PBX does not hear the ringing of the cell phone or the person on the cell phone talking. The person on the cell phone does not hear the person on the PBX talking.
I have tried allow=ulaw and allow=alaw
The current settings are peer details are

Second problem the SPA 400 is not answering inbound calls. I can see the light on the line flashing when it phone is ringing and it never answers it. the answer after setting has been tried on 2 and 3 rings.

I don’t think the problem is with the PXB setup as the spa400 should answer the line and it is not doing that. The spa400 is showing in the SIP registration status Registered.


It is not the firewall as both the FreePBX and the SPA400 are on the same subnet 10.0.1.X

The cell phone is not on the 10.0.1.x network therefore you must be using some sort of external voice trunk. Are you using a VoIP trunk or analog trunks. If VoIP then it is probably the firewall blocking RTP traffic.

It would also be helpful to know what version of FreePBX. Distro or built by hand?

Perhaps its your firewall, have you checked that?

The phone lines are analog lines connected to the SPA400.
So the path of the call is desktop phone to FreePBX to SIP Trunk to SPA400 to PTSN phone line with Verizon to the cell phone.

So the call never goes through a firewall so I is not a firewall problem.

the FreePBX Distro is 2.210.62-1