Spa3102 cid


(Erdei Dominik) #1

Hello! I have a Linksys SPA3102 as a pstn trunk added to freepbx with a pjsip trunk. All of the calls are working correctly (inbound and outbound), but I cannot make the caller id working. If I enable pstn cid for voip cid on 3102, I’m not get the inbound caller number at freepbx, I get only an annonymous. I tried to set the pstn answer delay to 10, but it didn’t help. The inbound number is coirrectly displayed at the 3102 status->last caller field. The Line 1 is also added to FreePBX as an extension, and it’s working coccectly.


#2

There are still some quirks with pjsip and devices like this (that have multiple ports and can send caller ID only in the From header). Possibly, setting Match Inbound Authentication will help; see

Or, try configuring the trunk statically (rather than Registration Receive).

If neither works, I recommend that you try a chan_sip trunk instead with these PEER Details:

host=dynamic
username=match-spa-pstn-line-User-ID
secret=match-spa-pstn-line-Password
type=friend
qualify=yes
context=from-trunk

The Incoming tab should be completely blank.

There is a quirk with this use of chan_sip. Use the same name for Trunk Name (in both General and Outgoing tabs) and for username in the PEER Details.


(Erdei Dominik) #3

I tried all of you wrote, but neither works. I attach some logs, when I configured it without registration, the problem was the same, I got the call from anonymous. (the default 5060 port is modified, it’s at 2552)

[2019-10-08 19:39:02] VERBOSE[19104][C-00000036] pbx.c: Executing [6747@from-sip-external:1] NoOp(“PJSIP/anonymous-00000071”, “Received incoming SIP connection from unknown peer to 6747”) in new stack
[2019-10-08 19:39:02] VERBOSE[19104][C-00000036] pbx.c: Executing [6747@from-sip-external:2] Set(“PJSIP/anonymous-00000071”, “DID=6747”) in new stack
[2019-10-08 19:39:02] VERBOSE[19104][C-00000036] pbx.c: Executing [6747@from-sip-external:3] Goto(“PJSIP/anonymous-00000071”, “s,1”) in new stack
[2019-10-08 19:39:02] VERBOSE[19104][C-00000036] pbx_builtins.c: Goto (from-sip-external,s,1)
[2019-10-08 19:39:02] VERBOSE[19104][C-00000036] pbx.c: Executing [s@from-sip-external:1] GotoIf(“PJSIP/anonymous-00000071”, “1?setlanguage:checkanon”) in new stack
[2019-10-08 19:39:02] VERBOSE[19104][C-00000036] pbx_builtins.c: Goto (from-sip-external,s,2)
[2019-10-08 19:39:02] VERBOSE[19104][C-00000036] pbx.c: Executing [s@from-sip-external:2] Set(“PJSIP/anonymous-00000071”, “CHANNEL(language)=en_GB”) in new stack
[2019-10-08 19:39:02] VERBOSE[19104][C-00000036] pbx.c: Executing [s@from-sip-external:3] GotoIf(“PJSIP/anonymous-00000071”, “1?noanonymous”) in new stack
[2019-10-08 19:39:02] VERBOSE[19104][C-00000036] pbx_builtins.c: Goto (from-sip-external,s,5)
[2019-10-08 19:39:02] VERBOSE[19104][C-00000036] pbx.c: Executing [s@from-sip-external:5] Set(“PJSIP/anonymous-00000071”, “TIMEOUT(absolute)=15”) in new stack
[2019-10-08 19:39:02] VERBOSE[19104][C-00000036] func_timeout.c: Channel will hangup at 2019-10-08 19:39:17.416 CEST.
[2019-10-08 19:39:02] VERBOSE[19104][C-00000036] pbx.c: Executing [s@from-sip-external:6] Set(“PJSIP/anonymous-00000071”, “receveip=pjsip,remote_addr”) in new stack
[2019-10-08 19:39:02] VERBOSE[19104][C-00000036] pbx.c: Executing [s@from-sip-external:7] Log(“PJSIP/anonymous-00000071”, "WARNING,“Rejecting unknown SIP connection from 192.168.7.5:2552"”) in new stack
[2019-10-08 19:39:02] WARNING[19104][C-00000036] Ext. s: “Rejecting unknown SIP connection from 192.168.7.5:2552”
[2019-10-08 19:39:02] VERBOSE[19104][C-00000036] pbx.c: Executing [s@from-sip-external:8] Answer(“PJSIP/anonymous-00000071”, “”) in new stack
[2019-10-08 19:39:02] VERBOSE[19104][C-00000036] pbx.c: Executing [s@from-sip-external:9] Wait(“PJSIP/anonymous-00000071”, “2”) in new stack
[2019-10-08 19:39:04] VERBOSE[19104][C-00000036] pbx.c: Executing [s@from-sip-external:10] Playback(“PJSIP/anonymous-00000071”, “ss-noservice”) in new stack


(Dave Burgess) #4

This message means that the PJ-SIP driver is not getting the call from the registered trunk.

After that, everything makes sense. For whatever reason, your 3102 is not registering with the server.


(Erdei Dominik) #5

Yes, because I configured the spa not to register, as Stewart1 said.


(Dave Burgess) #6

You have to either identify the host IP address and connect via the IP address (without registration) or register the device. One or the other.


(Erdei Dominik) #7

Can you explain this a little bit more? I don’t have very much knowledge in voip.


#8

Make sure that for the trunk, Registration is set to None, SIP Server is set to 192.168.7.5 and try setting Match (Permit) to 192.168.7.5 as well.


(Erdei Dominik) #9

It works! Thank you, you saved my life.:smiley:


(system) closed #10

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.